Can't access the internet

Hi, having now reinstalled Qubes my version of Qubes is 4.1.2(R4.1). I’m not sure what you mean by the “sys-net” settings (Devices tab) but I found something which appears to be [Dom0] Settings: sys-net and in it there is a selected controller which is my wireless network adapter. Not sure what this means though?

I was also thinking about upgrading my laptop so I was wondering if you would happen to recommend a system that would avoid these problems please?

This is an important point. I expect that in such case, you should be able to use it on Qubes, too. Your WiFi card is managed by sys-net virtual machine. Which templateVM is it based on? You can try to change the template to Fedora-38 or Debian-12 and see if it helps. I am not sufficiently knowledgeable to suggest some troubleshooting here; I hope someone else could chime in. In genereal, Linux-specific troubleshooting should work. See also:

Also, if you have more than one USB controller, then you should be able to still create and use the sys-usb. You can find out by creating an HCL report.

Hi, thanks for taking the time to respond to me, it is much appreciated. I’m not entirely sure which template anything is based upon to be honest. When I installed it to USB originally I left the defaults which were Fedora, Debian and Whonix templates, so not entirely sure what is based on what? Should I reinstall it again and just select the templates one at a time and see if that has an effect? To be honest when I said my wifi adapter worked with Linux I had used it with Mint and Ubuntu but not Fedora or Debian so not entirely sure that it would work with these distros.

Originally when I installed Qubes to the USB disk I got the following error after the templates had been installed:

Do you think that could have anything to do with it?

I also noticed that when I boot Qubes sys-net shutsdown and I get the following errors:

Again do you think this is part of the problem?

I managed to create an HCL report but couldn’t even find a file manager to transfer the document to a USB so I could upload, I’m not doing so well with this operating system. So I took a picture of it and I hope that helps:

Not entirely sure if any of this helps as I’m beginning to give up hope, sigh!



1 Like

Do you still have the installation media? If so:

Can you boot from the install media and check if the last option is “install Qubes OS with Kernel Latest”?

If you have the option to install with Kernel Latest, would you be willing to redo the installation (with kernel latest) and see if “kernel latest” will support your WiFi card?

1 Like

It seems the information about your USB controllers is only in the .yml file, not on the screen.

sys-whonix VM provides Tor connection, so it should not be relevant here.

These seem very relevant. I tried to search for such error on this forum and found this and this. Those threads have some solutions, which hopefully can help you.

I guess this short intro might help you to understand the general idea of Qubes OS.

Open Qube Manager by clicking on Qubes Domains widget in the system tray. You will see the list of all your VMs with the corresponding templates. You can check and change the template for each AppVM right there. You probably don’t have installed Fedora-38. Here is how to install it: Fedora templates | Qubes OS.

If some distros support your WiFi adapter, then it’s likely that other distros support it too.

Hi, thank you so much for getting back to me. I do appreciate you patience and willingness to help me out. I also like the quotes thing although not sure that I’ve done it properly. Anyway, if it works I had a look at the Qube Manager and I was quite impressed to see all the VMs and their corresponding templates. Unfortunately, it didn’t tell me what template dom0 is based. The manager just referred to it as ‘AdminVM’. I don’t suppose you’d happen to know what dom0 is based on?

Oh and I forgot I don’t currently have Fedora 38 but why would I need it? Sorry that this is the third time I made that comment I’m still getting my head around this forum and just realised I can edit the previous post, doh!

Oh and forgot. What would I need Fedora 38? And you are right I don’t currently have it

Oh and forgot. What would I need Fedora 38? And you are right I don’t currently have it

Hi, so far I’ve had a look at one of the forum posts you were kind enough to find for me and found this:

Since you’re using USB drive then after calling:
sudo qubesctl state.sls qvm.sys-usb
Since it doesn’t know that you’re booting from USB drive it’ll by default create the sys-usb that would contain all your USB controllers including the one to which your USB drive is connected. So when you start sys-usb it’ll remove USB controllers from dom0 and your dom0 will lose it’s drive with filesystem.
You need to determine which USB controller is used by your USB drive and remove it from the list of passed through PCI devices in sys-usb.
You’ll need to reboot Qubes and disable your VMs autostart to prevent sys-usb starting:
Autostart troubleshooting | Qubes OS.

I think in a previous response you told me how I could determine how many USB controllers I had and I posted an image of those results. Do those results mean that I have only one USB controller and therefore I won’t be able to isolate it as it is also being used by dom0? If that is the case would the only option I had then would be to install Qubes directly to my hard drive, which I don’t really fancy doing?

Hi, thanks for the response, it is much appreciated. I do in fact have the option to install with Kernel latest which seems to be and will now try and reinstall using that. I’ll let you know how I get on in due course.

I do like that short intro although I think it provided more confusion.

As I said above:

Dom0 is not an AppVM, it’s not based on a Template. It simply runs Fedora-32, however AFAIK it should not matter for your particular problem.

You have to share the .yml file with us. For this you need to copy it from dom0, as I said above.

Thanks. I would appreciate any comments about how one could improve that text.

Having now reinstalled Qubes with the most recent kernel (I think), I am still getting the same problem.

Phew! I managed to figure out how to copy the .yml file to a USB in Qubes, yay! I’ll attach it here and I hope it helps.

I’m now getting a bit confused as to where I’m at as this is getting a bit complicated. Anyway, I also checked my sys-net and it is based on Fedora 37. So how would I change sys-net to something else?

Qubes-HCL-HP-HP_Pavilion_Laptop_15_eh0xxx-20230703-201916.yml (858 Bytes)

1 Like

usb: |

It actually shows that you have two USB controllers. You need to check if it’s true: You can go to the Qube Manager, find sys-usb qube, open its Settings, tab Devices. Does it show two USB controllers selected on the right hand side? What are their names? (Sometimes, the system is mistaken and one controller can be shown as two. I have such situation by the way on my machine. I do not know how to reliably find it out without experimenting.) One of them definitely contains your USB boot device, so removing it would break your installation… Another one, in theory, could be removed from sys-usb and added to new sys-usb-2 qube (or something)…

Try right click on the qube in the Qube Manager. The Template can only be changed when the qube is not running. It will replace the /root partition of the qube. Alternatively, you can change the Template in the qube Settings, tab Basic.

Actually, this should not be very complicated. Your Internet does not work. Two possible solutions: (a) make WiFi work, or (b) make ethernet work. Because the latter is a USB device and you booted from another USB device, this is complicated. Option (a) should be easier.

For option (a), you probably need to install the firmware. Most of the time, latest Linux versions already contain it and it should just work. Your WiFi card is attached to and managed by sys-net virtual machine. It is based on Fedora-37. You can try to make it Fedora-38 in the hope that newer kernel will fix your problem. Alternatively, you can try to make it Debian-12.

By the way, it seems here is a similar problem with another solution:

Wow, who knew I had two USB controllers, well I do now. I checked in Qube Manager and it doesn’t list a sys-usb. Does that mean that I have to create it as I did previously?

Ok, when you put it like that it does sound easier. I think I was just getting confused as there seems to be multiple threads and things to try. But you clarified very succinctly. I tried changing the sys-net template to debian-11, I didn’t have debian 12 but still with the same problem. On boot sys-net tried to start but then shutdown. Fedora 38 isn’t listed as an option that I can change sys-net to. The only other options are whonix-gw-16 and whonix-ws-16 but didn’t try them.

If I apparently know that I now have 2 USB controllers is it also possible that I could isolate one for my boot device and one for my USB Ethernet card. Although I’m not sure how I would go about that? This might achieve option b, what do you think?