Nothing appears in the Packages window and Package Updater is not working

I am having trouble installing and updating software in Qubes, even though I have read the documentation regarding it
I go on System Tools → Packages, and nothing appears for me in Packages, even when I search for anything. Also, on System Tools → Package Updater, Package Updater says ‘Could not get updates. Failed to process request.’
I want to update the Electrum bitcoin wallet and the Monero Wallet as they are outdated, and I dont know how to. Also I want to install softwares like Google Chrome and Zoom.

Hi @adamrichards, welcome to the Community. Qubes OS is a very different system than others. You do not install or run any software in the AdminVM (dom0): You only use it to manage virtual machines.

Here is my super-short introduction to Qubes:

When you boot into Qubes OS for the first time, you will have the following virtual machines for your service. Sys-net contains drivers for your WiFi card and connects to the network, so it’s untrusted by default (don’t run Firefox there!). Sys-firewall protects you from DMA attacks and allows to use the Firewall rules in Settings of other qubes. Sys-whonix provides Tor connection to anon-whonix (in which you should run Tor browser). All connected usb devices go to sys-usb qube by default, to protect you from USB attacks. If you need to connect them to other qubes, use Qubes Devices widget. Vault qube has no network by default, making it a good place to store your secrets. With personal and work qubes you can separate your private and working lives by running related things in them (e.g., two independent Firefox browsers). See this for an example.

You should install software in TemplateVMs: How to install software | Qubes OS.

If you have any questions, feel free to ask here or create a new topic.


Sorry for the necro, but the title of this post is spot on for my issue and it wasn’t technically answered as far as I can tell… I’m also new to Qubes, but hopefully a little less confused than op was.

While I understand the attempt to install a wallet doesn’t apply to the question(since that’d happen inside a template), I’m still confused about the lack of connection with the package updater.

My system has internet, I’ve updated dom0, fedora, debian, and whonix ws+gw using the qube manager, as well as double checking with the normal terminal commands.

I’ve installed software on templates, and can add them to my app cubes and run them fine. I can browse the internet via my work cube (sys-firewall) or on anon (sys-whonix).

I’ve checked the updates proxy file, as suggested in a few threads I found while researching this issue, and it seems to have the correct default settings (I’ve tried a few different suggestions anyways).

Everything seems to work fine, both qubes os and my templates/cubes… All update commands seem to work… Except when I go to system tools → package updater, which errors like I don’t have internet(cannot update repo ‘qubes-dom0-current’: cannot prepare internal mirrorlist: curl error…).

Is this normal? Am I just missing something obvious? It hasn’t been a problem yet since I can install/run software in cubes, but it’s making me worry my firewall isn’t properly setup/updated/secure.

That’s as expected.package updater is in dom0, which should not have internet access and therefore the error you see is valid.

I’d worry if you were seeing anything else.

1 Like

@HELPME is right, dom0 intentionally has no Internet access. Dom0 should be updated in the same way as the normal qubes, i.e., with the Qubes Update tool: How to update | Qubes OS.

1 Like

@HELPME @fsflover Thanks for the quick answer to the both of you! Glad to know I’m doing everything right so far.

So just out of curiosity then what’s the point of having “Packages” and “Package Updater” as options in the system tools? I know Dom0 gets temporary internet access indirectly through the proxy UpdateVM when updating via qube manager or terminal… So why not:

      1. Give temporary internet access through UpdateVM for the package updater
      OR (if it's 100% redundant)
      2. Remove packages/package updater from the system tool menu

I spent an absurd amount of time trying to get the package updater to work before I realized it wasn’t needed… So mildly annoyed by it (lol). What’s the benefit of not doing one of the above options that’s outweighing the negative of confusing the crap out of newbies like me?

I agree, it’s confusing. (I went to look for it myself; it’s absent from my menus but that could be because I am using KDE.)

I’m going to guess that it’s something they inherited from xfce, and they just never realized it was still there and that they ought to remove it. (And they’re pretty busy so maybe they just didn’t have time.)

For that reason, in general, I’d look in the qubes tools first when I want to do something, and only if I can’t find it, then go on to “system tools”.


Agree that it should be removed. Please feel free to open an issue for this, if one doesn’t already exist.


The problem is that the Fedora tool doesn’t seem to honour the proxy
setting. (dom0 doesn’t get connected to the internet for updates, it
remains offline but uses a connection over qrexec to a network connected
In Debian you can use gui tools because they do.

I say “seem to” because I haven’t investigated this in any way other than
noting it does not work.
There is already an issue noting the fact that gnome-software does not
work.#3815 - that needs to be investigated before deciding whether to
remove the tool.
#6310 contains further discussion and alternatives.