Automatic startup of Gnome environement

Hi ,

in my newly created Office Qubes i installed the Gnome environment, since I am familiar with it since many years during the time i worked with UBUNTU.

Where do I have place which GNOME component to get the environment started, whenever the Office Qubes starts ?

The template i use is DEBIAN 12.

regards, hitam

Please explain what you mean by this, and what you want to happen.

I never presume to speak for the Qubes team.
When I comment in the Forum I speak for myself.

Do you want to have full desktop window in dom0 with your qube apps inside it without using Qubes OS GUI integration that will give each app in your qube a separate window in dom0?

Sorry, for the misunderstanding.

If i start my qube Office it should automatically start the gnome desktop environment to be able to wok normally inside a standard gnome setup.
The Gnome environment is installed within the qube Office.

thank you for your information.

However applying the info does not change anything. I start the Qube–> Office -->menu with individual apps open–>select app–>opens single window. Sorry, that is not what i wanted.
After starting qube Office I just want to see the complete Gnome desktop - like in a standalone installation.

Sorry, again.

regards, hitam

If you created new qube Office following the steps in the linked topic then when you start Office qube the window with full desktop environment should be opened.
How exactly did you apply the info in the topic?

i created the new qube Office without the steps in the linked topic.
I created the qube with the new qube option.

All steps are required.
You can create new StandaloneVM based on template using “Create Qubes VM” GUI tool.
Then enable debug mode for this qube using GUI Settings → Advanced tab → “Run in debug mode”.
And also change Virtualization mode using GUI Settings → Advanced tab → Virtualization to HVM mode.
Then open your StandaloneVM console from dom0 terminal:

qvm-console-dispvm MyQubeName

Login in MyQubeName console and run this command:

sudo systemctl set-default

thanks for the info. I did as suggested.
After restart the qube only a blank terminal opens: the Login appears shortly, disappear and the terminal keep sitting there forever…nothing happens…no GUI startup…no Gnome Desktop…

Did you run sudo systemctl set-default in your qube’s terminal?
If not then open your qube terminal and run it there:

sudo systemctl set-default

Running it in qvm-console-dispvm MyQubeName is unnecessary, you can use the gnome terminal.

The return message said: it ceated a symlink…thats all. And then ???

Restart the qube.

i did, nothing happened…no gnome desktop…everything the same like before…

I’ve tried xfce template and it worked for me.
For gnome it seems that you need to remove qubes-gui-agent package.
Start your MyQubeName qube and its open console from dom0 terminal:

qvm-console-dispvm MyQubeName

Login in MyQubeName console and run this command:

sudo apt remove --purge qubes-gui-agent

Restart qube.

My template is DEBIAN12 NOT Fedora.

I’m talking about debian templates as well.
There is a xfce debian template - debian-12-xfce and gnome debian template - debian-12.

i use debian-12 template…

with this i created my Office qube…within the qube i installed the gnome-desktop with synaptic…this installation i want to start every time i start the qube Office.

So did you try doing this?

I’ve checked it with debian-12 gnome template and it worked for me.

Here are the full steps for gnome template: