Copy/Paste not working (if use graphical.taget)


I create Standalone VM from Template

qvm-create --class StandaloneVM --label  --property virt_mode=hvm --template debian-12-xfce new_vm

then enable debug mode:

qvm-prefs  new_vm debug True && qvm-prefs new_vm kernel ""

then i boot (and connect console qube):

systemctl set-default  graphical.taget

then poweroff and run vm boot and see lightdm login and not working copy/paste

if disable graphical.taget, I can run only individual applications and copy/paste (ctrl+shift+c/v) via qube working.

How to make it work (copy/paste) on the entire desktop? And why do you have to enable debug mode when you create from a template? If we create standalone VM (new) from iso (we see window boot vm), without enable debug mode.

Qubes GUI agent is responsible for seamless mode (run only individual applications instead of full desktop) and for global copy/paste. So if you use the full desktop then Qubes GUI agent won’t work and global copy/paste won’t work as well.

Thank you for the explanation.