Are all Qubes ISO corrupted? No additional software, no templates, no default Vms. Stuck with only Dom0

Are all Qubes ISO corrupted? No additional software, no templates, no default Vms. Stuck with only Dom0.

Hi everybody. First of all, I’m sorry for my broken english.
I’m here to address an issue that seems to affect very few people, but also seems to be disruptive and insormontable.

I specify that I’m a Qubes user since 2017: I used this OS during the 2017-2019 period, then back again on it in 2022, and today I’m trying to reinstall it.

The issue is that, doesn’t matter what procedure I follow to flash the iso and install the OS, I’m unable to install the needed templates and the default Vms. I’ll leave you some pics that testify how the issue present itself:

First of all, here are the bios settings on my main machine.

As usual, I flash the iso on the USB drive (tried dd, rufus, etcher: more on that later) and verify the media and the gpg signatures. Then, after the boot, you can see the first symptoms of the issue:

As you can see, in the software selection page, the templates are totally absent. I can only install the Qubes UI.

I also tried to test the installation media, it seems ok.

At this point, if I proceed, the installer executes itself and bring me to the reboot. After the reboot, in the post-installation phase, this is the first thing that seems wrong:

Whonix not available, fedora and debian not even mentioned, and all the options (except the advanced configuration options) are greyed out.

If I go further, in the terminal post-installation phase, the systems gives back this message:

At this point I can boot Qubes and log in, but I’m stuck with Dom0 and only Dom0. No templates at all, and no pre-configured Vms. I know that there is probably some workaround to this issue, like installing the templates after the Os installation, but I’m not an expert user.

On the forum, a guy told me to run this command in the dom0 terminal, so I leave you also this picture.

To better address the problem, I tell you that I tried all the possible combinations between the following alternatives (I’ve been on it for the past 3 days):

Downloading the iso:
Tried both from the main qubes website, from the torrent and from multiple mirrors. Tried to flash the 4.2 stable, 4.1 stable and 4.1.1 rc5 (the last time I installed qubes, in 2022, I flashed and installed this last iso and it worked flawlessly). Downloaded the iso both in linux and windows environment.

Flashing the iso:
Tried rufus (both DD and ISO mode), etcher and the dd command in linux environment. Everytime I flashed the iso in a linux environment I did also all the integrity and signature checks, and everytime they passed

Target machine:
The bios settings you see are from the machine with I always used qubes in the past. Anyway, I tried to change the target machine 3 more times:

  1. ASUS UX305UA-FB004T Zenbook, i7-6500U, 8GB Ram
  2. HUAWEI MateBook X Pro, i7-8550U, 8GB Ram
  3. Lenovo IdeaPad S145, i3-8145U, 8GB Ram
    Everytime I got the exact same result

Changed 5 different USB drives, also tried a USB 2.0 drive. Tried all the different ports on all the different machines: nothing changed.

Last thing: As you can see here, this isn’t really the first time I encountered this issue. But the last time, in 2022, I was able to resolve it by downloading the 4.1.1 iso (at that time it was a beta version, since the stable was the 4.0). Here you can find the discussion: All templates MISSING from fresh installation
That brings me to think that there is something wrong with Qubes iso, and not with me.

I hope someone can help me: if I can no more install qubes I’ll have to step back to Tails, where I don’t feel secure at all.

Thank you for your time, have a nice day.

Hi Gianmo95

I’m fairly sure, that the majority of Qubes ISO are fine – which results did you get when you verified the download:


I don’t have a test machine (within reach) - but I’m fairly sure it’s to be expected that the “software selection” is as you showed (with the options “Qubes OS with Xfce” and “Qubes UI (Audio/Gui)” - I’ll try to check later).

To me, the real question is “why did the installer not put any files in /var/lib/qubes/template-packages/??”. Without those files, the “INITIAL SETUP” shows the grey “Whonix not available” … where it should give you the selection for “Fedora 38” and “Debian 12” (iirc).

Without any templates selected (since the rpm-files are missing in /var/lib/qubes/template-packages), I would expect the INITIAL SETUP to fail in spectacular ways … the script probably assumes those are available. :slight_smile:


I suggested that you downloaded one of the missing rpm-files (the URL to download the rpm-file from is: Index of /r4.2/templates-itl/rpm/) and manually added it to /var/lib/qubes/template-packages/ before running INITIAL SETUP … did that solve the “[Dom0] Error (on dom0)” ?


templates are only available for selection in the post-installation phase

Could you try to install one more time but just don’t do any changes to the default installation settings? Just in case…

This seems a bug, maybe related to a setting at the installer time.

ISOs files are fine, I used the installer recently and the ISO matched the signature, so if you do so as well, this means we are both using the same ISO but with different results.

1 Like

Hi chris. Thank you for your suggestion.

Unfortunately I don’t know how to manually add the rpm-files before the initial setup. How I can mount the usb drive and copy the files directly in dom0?

I’m more advanced than the average Joe, but I’m not an advanced user.

I would be grateful if you can point me to a step by step guide for this.

Thank you again.

Hi solene.

Indeed, as you can see, the templates are available before the post installation phase:

The picture is from the qubes installation guide page.

The last 5 times I tried to install the OS I didn’t do any changes

1 Like

Strange, I don’t remember seeing anything on this page on the right side. I’ll try in a VM

That was like that in older versions of qubes os.
You had to chose what additional templates you want to install at installation phase (at Software selection menu).

This was changed in recent versions.

Hi Gianmo95

If you click the link I shared, you should see:

  1. Download the Fedora 39 template
  2. Install a fresh Qubes OS 4.2 and stop the installation in the INITIAL SETUP
  3. Open an Xfce4-terminal

Most of them have a text in monospace – those are commands to be run … eg. “to mount the second USB-stick” the command would be

pmount sda1

and to “copy the downloaded/updated template” the command is

cp /media/sda1/qubes-template-fedora-39-xfce-0_4.2.0-202311171322.rpm /var/lib/qubes/template-packages/qubes-template-fedora-39-xfce-4.2.0-202312171103.noarch.rpm


Thank you chris. Tomorrow, as soon as I can, I’ll try this.
As I understood I should carry the installation untill the reboot, and then don’t start the setup but open up the terminal and copy the templates. Is that correct?

I still don’t recall the possibility to open the terminal in that phase.

Anyways, thank you for your help.

The INITIAL SETUP will start automatically when the machine reboot … but it has a “QUIT” at the bottom left, where you can stop the INITIAL SETUP:

Note that it ask/warn you:

… but your system is broken in the first place, so … :wink:

Re-reading my steps, I seems to have forgotten a step between “3” and “4”:

Become the SuperUser (sudo -i)

– the alternative is to put sudo in front of the commands in step 4., 5. and 6.

If you have to reinstall the machine (or can just boot from the installer and test), could you try:

  1. At the “INSTALLATION SUMMARY” press Ctrl-Alt-F2
  2. Change to the directory /run/install/sources/mount-0000-hdd-device/Packages/ (cd /run/install/sources/mount-0000-hdd-device/Packages/)
  3. List files matching qubes-template (ls -al qubes-template*)

I’ve had my test-machine booted … and the options for “SOFTWARE SELECTION” are:
Base Environment:
“Qubes OS with Xfce”
Additional software for Selected Environment:
“Qubes UI (Audio/Gui)”
– so in that sense, your installer looks correct.


Could you create a github issue in GitHub - QubesOS/qubes-issues: The Qubes OS Project issue tracker ? This is a bug, the installer should works out of the box for everyone

I’ve seen several cases lately, where the list of available Templates in “INITIAL SETUP” is empty … but not spotted a reason why nor found a place in the source to look … :-/


Hi solene.

Issue created at All templates and default qubes missing from fresh installation (only dom0 exists) · Issue #8993 · QubesOS/qubes-issues · GitHub

1 Like

Hi chris,
Don’t ask me why, but yesterday I tried for the last desperate time and it worked. All templates where there, and all default Vms got installed.

The ISO was flashed on the USB drive with the dd command in linux environment.
I tried to use the last USB drive that I never used before to install.

The main difference with the previous times was that during the initial setup (post-reboot phase) I left the USB drive inserted. I don’t know if this is the problem.

the installation guide says

When the installation is complete, press Reboot. Don’t forget to remove the installation medium, or else you may end up seeing the installer boot screen again.

so I don’t think it’s related to the issue :+1:

This is interesting observation - thanks for the care.
Was there anything else you can think of about this install?
Did you take things slower? Faster?Much the same?

Since the installation is brand new, would you be willing to test if the issue could be reproduced by reinstalling and removing the USB when rebooting the first time?

… and if the issue returns, then test if it can be resolved by reinstalling and leaving the USB connected at reboot?


Since the USB-stick worked for the installation, I think we can conclude that at least the ISO you wrote to the stick, wasn’t corrupted - so the answer to “Are all Qubes ISO corrupted?” would be a “No:wink:

Sorry to people following on mail - this is for fun/humor and doesn’t deserves a mail on its own

1 Like