Any way to switch between VPN files? That would be good to have

Hello. :wink:
Hope someone can help me with one thing… I like using a VPN in this day and age when every human being has become data for profit… For those companies that is. They are the only ones getting profit while invading peoples privacy.

Anyways! I used this link for a VPN.

With the CLI scrips. I like it! But… I use the same VPN file every time…

Would it not be nice to be able to switch kinda easy? Would that not make Qubes even better?
I’m almost thinking like a mac address settings where it is cloned by random, but maybe the same as VPN, if you have a few config files it changes between…
Now one would have to manually rename a file to change the VPN connection right?

If i could pick one VPN i like to have in some easy menu that would be even better. Is this possible in some easy way? Thanks!

1 Like

Haven’t followed that guide myself, but it is kind of outdated.

I would recommend the following guide, where almost no terminal is needed and you can visually change between VPNs using the network manager widget:

With this other guide (and associated community package) you can switch it by root@sys-vpn:/home/user# cp user_config.ovpn /rw/config/qtunnel/qtunnel.conf:


Thanks for sharing your knowledge. :slight_smile:

1 Like

Ok Deeplow. I got two connection icons now and they both seem to work. The one i linked before, and then tried this GUI method… Visually. And it seems like i have two vpn connections at the same time then next to eachother. :slight_smile: One has the VPN lock icon and the other one do not have it, that’s all. But they are both connected.
But that should not matter right? I switched the personal one to the one i tried now in qubes settings and the connection. Dom0 settings personal.
So it seems to work! Two ethernet icons left to the volume button looks nice, and i can switch one of them with the files i add, and choose which i want. The other is the same though still so i might remove it later on.

And i don’t see why i should not have two… Any issues i dont know about with this setup?
If i try ipleak, i don’t get an ipv6 address that’s all. IPv6 test not reachable. (error).

But it seems i can just switch VPN in the meny now in one of the menus. Thanks

Yes. that is ito be expected. One of them is the network manager of the sys-net qube and the other one is for the vpn qube.

I wuld encourage you to ask that question on the other tutorial’s discussion as I am not the one who posted.

All credit goes to @den1ed. I simply linked to it.

ok yeah thanks. :wink: Works good thanks to both of you.