4k font size dom0 vs vm

Hello. I have a 4k 15.6’’ screen. I use custom DPI settings 126 (dom0->Appearance).
As you can see on the enclosed screenshot, on the right there is a Dom0 Window Manager, the font is readable. But, on the left there is a VM file explorer that still has the small font size.

Could you please explain me how to adjust the font size in this VM file explorer to have large font everywhere (path, file name, shortcuts in the left column of the file explorer).

I’m guessing these aren’t passed along to the AppVM. Perhaps changing the settings as well on the Template on which that AppVM is based.

1 Like

this thread seems to be a clue. But I still have not resolved the issue. I use Fedora-32.

this thread also does not work for Fedora 32.

bump

It was last updated in 2019. Maybe it needs a refresh from a community member.

@user2 I would try and look up guides on how to do that on fedora 32 generically and try to implement that solution on your template. That part should not be qubes-specific. If you manage to find it that way, feel free to report back what settings solved your issue. (or maybe even update the guide).

1 Like

Could you please explain me how to adjust the font size in this VM
file explorer to have large font everywhere (path, file name,
shortcuts in the left column of the file explorer).

It depends what template you are using. If you use the standard Fedora
template, simply install gnome-tweaks in the template. Then launch your
AppVM and run gnome-tweaks and set the respective DPI value.

In other templates that do not run the gnome settings daemon, you simply
should add

Xft.dpi: 126

to your /etc/X11/Xresoruces or /etc/X11/Xresources/x11-common depending
on the distribution.

That will take care of it in all AppVMs based on that template.

I have a 4K display too and found this page invaluable:
https://wiki.archlinux.org/title/HiDPI

1 Like