Tiny Icons

Does anyone know how to make the qubes Vms icons bigger and the bar when you open them everything looks tiny I can barely read them, I already change the letter size System Tools>Appearance but when I open a VM or the actual VMs icons are extremely small ?
I’m using a Lenovo X1 Carbon gen 9

Are only the icons small or everything? Are you using a high-resolution screen and might just need to change the dpi settings?

I adjusted the DPI settings already and they fixed the letter size but the actual icons of the VMs the colour ones are tiny and when I open wherever VM on wherever template it looks unreadable, if I open Firefox it looks very tiny I’m not even able to browse.
I’m using a 4k !

By the way I’m running 32GB of RAM and it’s extremely laggy!!!

Did you change the dpi settings inside the VM or in dom0? Ideally you do both, you definitly need to change the settings in the VM as well.

I am doing the Xft.dpi, the gsettings stuff and for some minor stuff (mostly mozilla stuff), I am also setting GDK_SCALE and GDK_DPI_SCALE as described here.

Yes but I just can’t make it work, I didn’t understand the instructions very well !!

If your problem is the way I think it is, you might try the following:

Open a terminal in the AppVM you want to use the firefox. Set the following two variable and open firefox by typing into the terminal:

export GDK_SCALE=2
export GDK_DPI_SCALE=0.5

Does this look much better? These settings apply scaling for all GTK-based applications (so also the “files” application, the pdf viewer etc.). I found this to be necessary, although it is not included in the documentation.

If you like what you see, you can make this permanent for all AppVMs by creating a file into your template vm. For this you need to create a file /etc/profile.d/dpi.sh in your template vm (e.g. fedora-34) with the following content:

export GDK_SCALE=2
export GDK_DPI_SCALE=0.5

This makes these setting permanent for all AppVM and all their applications.

If this is not helping you or it is not what you are looking for, please let us know what exactly you tried so far and what templates you are using and may even provide a screenshot or similar.

1 Like

Thank you for the answer, I will try this later and I will tell you how it goes !!

Hello again, I just tried the commands and they fix Firefox temporarily, but let me explain when I open up Qubes and I go to my Qubes manager the little Color Qubes for the VMs look ultra small and when I try to use the terminal it is almost impossible to type in because the terminal open so small that I can’t see what I’m typing.
Thanks for the help by the way!

That sounds like you are missing settings in dom0. Depending on your display manager (xfce4 is the default), you need to change the basic dpi like describe here. Did you try this? This should do the trick for most of the stuff outside the VMs.

I try to summarize the changes I did in my fedora-34 template the next days, once I find some time to do it thoroughly. This should fix consequently fix problems inside the VMs.

This works on Fedora but I could not get it not work on Debian.

What did you do exactly? I successfully applied this to both my fedora and debian templates.

You still need to do the gsettings stuff as well. This is no fix on its own, it is just to get the icons in firefox and Co. right.