[4.1] Xfce menu vanished

Some help here would be appreciated.

The menu bar just vanished. Won’t come back after a reboot.
When I try and get into the panel settings (via Alt-F2 launcher), I get

Failed to show the preferences dialog
GDBus.Error:org.freedomdesktop.DBus.Error.ServiceUnknown: The name is not activatable

Can someone help?

OK, running ‘xfce4-panel --disable-wm-check’ seems to have gotten the menu back, but has thrown a whole load of warnings about service files not being provided.

If I stop this process, the menu vanishes. The menu is also now being run as root.

Perhaps this could be helpful:

Thanks, that helped.

However, the problems seem to be increasing.

When I boot, there is no menu, I have to use the method above to get it to appear.
sys-usb now fails to start
I have no network connection, and the icon for network connection isn’t in the menu, what is the application named?

I have updated from fedora-34 to 35 over the weekend. It seemed to work fine until yesterday, when there were a couple of fedora 35 updates. Dom0 hasn’t updated in the last while.

Can anyone help / suggest anything?

I have found the following to be helpful to fix the panel not showing:

[user@dom0 ~]$ mkdir -p ~/xfce-bak
[user@dom0 ~]$ mv ~/.config/xfce/* ~/xfce-bak

Then log out and log back in (or reboot).

If it still doesn’t start after a reboot, try the following:

[user@dom0 ~]$ mkdir -p $HOME/.config/autostart
[user@dom0 ~]$ cat <<EOF > $HOME/.config/autostart/xfce4_panel.desktop
[Desktop Entry]
Name=Xfce4 panel

Thanks, I will try that. However, I’m confused as to what caused it to stop working in the first place…

However, if I try and update Dom0 I now get:

(zenity:1288): Gdk-Critical **: 0 [a time stamp] gdk_atom_intern: assertion ‘atom_name != NULL’ failed

… …/gdk/x11/gdkproperty-x11.c:224 invalid X atom:611158387

Tried the above, neither worked.

Try adding --restart to Exec=/usr/bin/xfce4-panel:

Exec=/usr/bin/xfce4-panel --restart

no change, I’m afraid
Something seems to have broken in dom0’s X config.

Where would be the best place ot check logs?

Just to confirm, did you logout/restart after creating the .desktop file?

yes, rebooted after each attempt

Just making wild guesses:

[user@dom0 ~]$ journalctl -r
[user@dom0 ~]$ sudo grep -r "gtk" /var/log
[user@dom0 ~]$ sudo grep -r "xfce4-panel" /var/log

See if you can find any meaningful errors

Perhaps some potential leads:

Service file ‘/usr/share/dbus-1/services/org.xfce4-notifyd.Notifications.Service’ is not named after the D-Bus name ‘org.freedesktop.Notifications’
Service file ‘[…/]org.xfce4.Thunar.FileManager1.service’ is not named after the D-Bus ‘org.freedesktop.FileManager1’

pciback 0000:00:1d.0: xen_pciback: cannot enable memory-write-invalidate (-22)
pciback 0000:00:1d.0 cache line size of 64 is not supported.
Same for 14 and 1 (in place of 1d)

libvirtd[3266]: internal error: Unable to reset PCI device 0000:00:14: no FLR, PM reset or bus reset available

From /var/log
Lots of Gtk warnings about drawing a gadget with negative dimensions
Failed to terminate process 6271k, no such process

Is that your network controller attached to sys-net or USB controller attached to sys-usb?
Try to add no strict reset option to it to make it work:

I was able to get the panel to show up by adding the command xfce4-panel to the startup and sessions tool.

The PCI trick also seems to have solved the qubes-usb not starting.

However, I am still getting the error on Dom0 update attempts. SHould that be a new thread?

Does the network work for you in qubes?

Yes - that is working also, and the gui icon is back.

Then what’s the error that you’re getting when you try to update dom0?

(zenity:1288): Gdk-Critical **: 0 [a time stamp] gdk_atom_intern: assertion ‘atom_name != NULL’ failed

[Same as above] /gdk/x11/gdkproperty-x11.c:224 invalid X atom:611158387

What if you run update from dom0 terminal?
sudo qubesctl --show-output state.sls update.qubes-dom0
How to update | Qubes OS

Or try to run Qubes Update from dom0 terminal:
And see if there are more errors.