XPS 13 plus (9320)


The issues i’ve experienced with Qubes seem to be very familiar to similar hardware which uses the newline of intel hardware (p-series CPU’s and Intel Xe GPU line).

  • extremely laggy install process and usage afterwards (to the brink of unusable). Possibly similar issue to HP Elitebook 860 G9 as it uses the same CPU (12th Gen Intel(R) Core™ i7-1280P) and same GPU (Intel Iris Xe Graphics). Installing kernel-latest (6.0.8-1.fc32.qubes.x86_64) combined with this github issue fixed the choppy behaviour: Graphics artefacts with Intel UHD Graphics 770 and kernel 5.17.7 · Issue #7507 · QubesOS/qubes-issues · GitHub
  • no wifi. Fixed by installing an unstable release of iwlwifi (hxxps://packages.debian.org/bookworm/firmware-iwlwifi) in the sys-net qube.
  • qvm-pci fails with: Failed to list 'pci' devices, this device type either does not exist or you do not have access to it., but lspci works fine. USB passthrough seems to work too.
  • Scaling on 4k is messed up, but manually setting Xtf.dpi: 255 in .Xresources makes it all readable (not really a Qubes issue though)
  • No audio (need to debug more to fix)
  • Laptop a quiet weird noise coming from it (possibly hardware issue, but didn’t notice the sound when testing ubuntu on it). Possibly related to the mouse somehow, as when you move the trackpad the noise faints.
  • Sleep is broken
  • Boot up and shutdown is rather slow and hangs because of systemd-udev (on boot: Failed to start udev Wait for Complete Device Initialization, on poweroff: waiting for process: systemd-udevd which eventually just gets killed by systemd due to dracut: Dracut Warining: Killing all remaining processes


brand: |
  Dell Inc.
model: |
  XPS 9320
bios: |
cpu: |
  12th Gen Intel(R) Core(TM) i7-1280P
cpu-short: |
chipset: |
  00.0 Host bridge [0600]: Intel Corporation Device [8086:4641] (rev 02)
chipset-short: |
gpu: |
  02.0 VGA compatible controller [0300]: Intel Corporation Device [8086:46a6] (rev 0c) (prog-if 00 [VGA controller])
gpu-short: |
network: |
  14.3 Network controller: Intel Corporation Device 51f0 (rev 01)
memory: |
scsi: |

usb: |

- works:
  qubes: |
  xen: |
  kernel: |
  remark: |
  credit: |
  link: |

1 Like

Thank you @segfault for your HCL report, which is online now!

1 Like

hello community

i am running latest qubes 4.2 on xps13 plus (9320). kernel version info 6.1.28-1.qubes.fc37.x86_64

biggest problem is power management – the sleep / hibernate is not working properly when lid is closed.

i tried to switch power setting to sleep , hibernate - none of them work.

here is the error message –
GBBus.Error:org.freedesktop.login1.SleepVerbNotSupported: Sleep verb “hibernate” not supported.

any fix or resolution to this issue? thanks

dug into this more.

apparently processor on my XPS is i7-1260P , which doesn’t support S3 sleep mode.

full s0ix support is still open issue in qubes

once this resolved, then sleep should work on this machine

in the meantime i need to shut down machine , before closing the laptop lid. otherwise all the power will be drained if not connected to power.

Hi @segfault , can you let me know if you were able to fix the sleep/suspend issue on the XPS13?

When disconnected from power , if lid is closed, the machine goes into a black screen and hard reset needed.

I also tried the latest 4.2rc3 and have the same behavior.


I can help to test fix if there are resolution steps and once Xen upstream is available
cc: @solene