Windows hvm crashing

Hi Everyone,

I installed windows 10 on Qubes 4.2 following the standard installation, no special drivers. I have enabled stubdom-qrexec in order to connect USB etc devices.
Once a while, the window for this HVM (is console the correct term for this?) just disappears. I’m not sure if the HVM halts or not. The HVM seems to still be running and using CPU (I don’t know if it is running properly), but I don’t have any graphical interface to it that I can use. It does not respond to shutdown, so I end up killing the VM.
This usually happens when I change the screen resolution in the HVM, but it doesn’t always happen when I change the resolution, and it has happened on other occasions. It tends to happen more after the appVM has been running for a while - changing the resolution right after I start the VM doesn’t seem to crash it.
My computer has 64GB RAM and the windows VM is assigned 12GB RAM. I tried to turn “include in memory balancing” on and off, but that doesn’t seem to matter. It is assigned 4 VCUs.
I don’t have any USB devices attached to the VM when this happens.
I usually have an extenral 4k monitor attached when I use windows.

Any ideas how to fix this? Is there a way to bring back the window (if windows is actually still running)? Any other ideas for ways around it?
Are there logs that might be useful?


Did you try qvm-start-daemon? Could be a crash of the GUI daemon…

I tried qvm_start_daemon vmname
and got the error message: Failed to send monitor layout: b'qrexec-client: qrexec-client.c:186:connect_unix_socket: connect: No such file or directory\n'

Hmm, so it’s something else; maybe someone else has an idea.

Also, you could post your issue on GitHub.

Thank you. It was worth trying. I also thought it might be something like this but didn’t know about the command you proposed.
If I don’t hear ideas here I will post on github.

1 Like

I have same problem of linuxmint HVM (window/GUI) disappearing whilst CPU/RAM still working.

I cannot reproduce but it happens on occasion when I ALT-TAB / ALT-CTRL-TAB, it seems like the cursor turns into a square hitmarker [+] and then when clicked on a window it disappears, looks like a (hidden?) function to close GUI/window but I don’t find in documentation (if I find I add later).

running qvm-start-daemon HVMname works and gets the window back, thanks @Bearillo !!!

@b34 you wrote qvm_start_daemon HVMname (_ vs -) which doesn’t work for me

It sounds like you have qvm-xkill bound to some keyboard shortcut you use for other things. Check your dom0 keyboard shortcuts (search for “Keyboard” with the Application Finder or App Menu).