Win10 clipboard issues

All my Windows10 VMs have a problem: when I press ctrl-shift-C i get the message “keyboard was copied to qube and cleared” and when I press ctrl-shift-V just nothing happens. I use crossbuilt QWT for now. Any ideas what could be the reason and how to fix it?

  1. on the vm you want to copy from (win10 vm in this case)
    ctrl+Cctrl+shift+C
  2. on the vm you want to copy to
    ctrl+shift+Vctrl+V

is this what you are following to copy and paste?

Yes, exactly. And it works as expected on Linux qubes.

this problem must have something to do with qwt
i saw you also post in this thread
are you using qubes 4.1?

Yes. Not sure if similar problem existed in 4.0, but I vaguely remember that something was wrong there with the clipboard, too :slight_smile:

Apparently my QWT installation is broken :-/ And I am not sure the .iso installed from rpm I built from github is ok. Is there a binary repo for cross-built QWT? upd: i see, there is a link in 4.1 thread. will try it now if it fixes anything.

Did you set qvm-prefs <VMname> default_user <your_username_in_ W10>? If not, the clipboard is copied to C:\Windows\System32\config\systemprofile\Documents\QubesIncoming\<source_VM>.

Yep, I did everything using the qvm-create-windows-qube script, so the user is set.

Resolved! Indeed the problem was in QWT, namely the compatibility issue with newer QWT and qvm-create-windows-qube script.

1 Like

I have this issue with my VMs in 4.0.4. I also used the qvm-create-windows-qube script. Often, pasting into the windows VM works most of the time. Copying out of a windows session is less reliable. It works 25% of the time. Sometimes copying and pasting into windows notepad and then cutting out of the windows vm (ctrl+x) will work but not often enough that its a reliable workaround. I have created multiple windows 10 enterprise and ltsc issue persists across all of them.

However, my biggest issue is in all my VMs I have created from scratch - none of the clocks stay in sync. None will sync with the timeserver and manually setting won’t work for long they will always lose sync.