Win 10 Pro hvm USB...BSOD SOLVED

So I cloned my WIn10PRO hvm so that I could test this process of getting audio & USB’s working. Well at best the "audio is (crack & pop) but the audio really doesn’t matter to me, what does is my USB’s. Once I attach a USB to the this Win10PRO clone it will populate in windows explorer and “What do you know”…BSOD every time I attach a USB it this.

I have autologon enabled
I followed this process…

Any ideas or help to get my USB’s working?

An idea… sounds like an interesting problem to root out.

Maybe there are some dynamically generated UUIDs for interfaces that no longer match or conflict with dom0 in some way? Are you able to attach Wireshark/NetMon to the usb interface in the HVM?

I tried that process before I update my win10pro as of this morning, so this update was today 05/01. Now before this 05/01 update I did a update on 04/12. So I was working from that update 04/12 to do this…
-Followed that process to the letter

  • made sure I had auto login enabled
  • installed the PV drivers &
  • I did the move user profile
  • rebooted all was fine, audio was sub par (crack & pop) but I really don’t care as I have other means to lister to videos/audio elsewhere.
  • attached a USB, saw it in dom0 get attached, saw it in my win10 hvm, it populated in windows explorer, tried to access USB and within 30 seconds or so…BSOD

Tried a few more times. My win10 hvm would recover, audio (snap,crack,pop). Still win10 hvm running good. Attach USB and… BSOD everytime.

So I deleted that clone. Updated my main win10pro hvm this morning 05/01. Hopefully thinking this would fix this. Actually it was a big update as well if I remember right a .net was updated, a win 10 features update, defender update, a cummlative win 10 update as well.

Follow same process and have the same results.

Now mind you I have 2 updates before trying this process. One on 04/12 & then 05/01.
So obviously something changed on the 04/12 update to cause this to happen and not the 05/01 update. Remember I did this before the 05/01 update which put me at 04/12 update.

If that process which may have worked before the 04/12 update this process does not work anymore after 04/12 update, at least for me.

I hope that it can be fixed as I would like to have USB use/access

Sorry I forgot… I am running win10 pro 21H2 I believe…

Have a good night everyone

So we are missing 2 key info here

  1. What kind of USB devices you are trying to attach, and
  2. How exactly you are trying to do that.

If you are trying to

  1. Attach USB storage devices, you should attach them via qvm-block, and not via qvm-usb, and
  2. if this isn’t enough you should try to attach them with persistent argument.

They are just regular USB 2.0/3.0 devices.

I click the storage icon up top on the taskbar,
go down to what USB device I want, click the + next to the name of hvm.
I see it attach to win10, I see it populate in windows explorer, about 30 seconds later…BSOD

So did you try in dom0 something like

$ sudo qvm-block attach --persistent win10 sys-usb:sdb

Not partition, sdb1, but the whole disk sdb, or whatever letters they have?

1 Like

@enmus no, but I will try in the morning and let you know, thanks

Well the terminal cmd you have me worked BUT

When I first did it

$ sudo qvm-block attach --persistent win10 sys-usb:sdb

Win 10…BSOD

I restarted and all of the sudden there my USB was in windows explorer and I can access it and save files to it. I even reformatted it.

I still have no sound but that does really matter.

I have copy and paste between domain and Win10!!!

1 Like

@enmus thank you very much my friend…

So if I want to attach a USB to my win10…

$ sudo qvm-block attach --persistent win10 sys-usb:sdb

How do I remove it from win10???

And will Win10 BSOD even time I attach a USB with…

$ sudo qvm-block attach --persistent win10 sys-usb:sdb

$ sudo qvm-block detach win10 sys-usb:sdb

1 Like

Try to use the command without persistent argument and check if it works. In that case you don’t need to shut down the qube in order to detach external drive from the win qb.

Thank you for the help as it is working. I am find with having to shut down and remove and reattach if needed.