WiFi network missing from Connections

Hi folks,

New to Qubes and Linux in general so please bear with me. I’ve easily installed Qubes onto a new Thinkpad T14s 2nd Gen. However, I’ve a couple things going on that I’m not finding clear direction on…

  1. during install I received an error along the lines of:
/usr/bin/qvm-start, sys-firewall failed
unable to reset PCI device, no FLR, PM reset or bus reset available
  1. i have no wifi in my network connections once I run sys-net

Based on my research, the only thing I’ve been able to figure to try was:

  • in Devices tab for sys-net I set the Wi-Fi network controller (an AX201) to strict reset

Also, not sure if or how related but, in sys-firewall settings there was a yellow warning icon next to Net Qube that stated the disposable template which sys-firewall was based on (debian-11-dvm) should be set to “none” so I did change the debian-11-dvm template’s Net Qube to “none” which ended up clearing that error/warning in sys-firewall.

Thanks for the assist.

Please check if any pci device is attached to sys-firewall (it should return an error):

$ qvm-pci ls sys-firewall

If instead some controller is attached to sys-firewall, you should detach it:

$ controller_id=$(qvm-pci ls sys-firewall | grep dom0 | awk '{print $1}')
$ qvm-pci detach sys-firewall $controller_id

Also, what template is sys-net based on? If you don’t know check with:

$ qvm-prefs sys-net template

Finally, check which pci controller is attached to sys-net, then re-attach it with the no-strict-reset parameter:

$ controller_id=$(qvm-pci ls sys-net | grep dom0 | awk '{print $1}')
$ qvm-pci detach -v sys-net $controller_id
$ qvm-pci attach -v --persistent --option no-strict-reset=True sys-net $controller_id

Thank you.

Returned only the following which doesn’t list any attached controllers:


Sys-net is based on the “debian-11” template.

That first line runs without issue. However, upon running that second and third lines i receive:

qvm-pci: error: unrecognized arguments: dom0:09_00.0

Then you need to download the bookworm version of firmware-iwlwifi: Debian -- Package Download Selection -- firmware-iwlwifi_20221109-2_all.deb

Download it in an AppVM then copy it to your templatevm and install it with:

$ sudo apt install -y /home/user/QubesIncoming/VMNAME/firmware-iwlwifi_*.deb

(change VMNAME accordingly)

Try to run those commands manually but instead of using the $controller_id variable, type the controller’s actual id: dom0:09_00.0

If you want to be sure, check that there are no other controller assigned to sys-net:

$ qvm-pci ls sys-net

This looked promising, being run in the debian-11-dvm template qube, but then at the end if the install it hit me with

Download is performed unsandboxed as root as file /xxxx/xxx/firmware-iwlwifi_*.deb couldn't be accessed by user '_apt'. -pkgAcquire::Run (13:permission denied)

I replaced $controller_id with dom0:09_00.0 but it tells error, an unrecognized argument dom0:09_00.0

You need to install it in debian-11, not in debian-11-dvm.
And that error shouldn’t prevent you from installing it.

Show the output of qvm-pci ls sys-net please.

Ah. Oops. Okay, I moved the file over to debian-11 and ran the install but received the same output with the same error at the end. If that error doesn’t prevent the install, how can I confirm it was properly installed?


dom0:00_1f.6 Ethernet Controller 
dom0:09_00.0 Network Controller Wifi

Both used used by sys-net with no-strict-reset=True.

apt info firmware-iwlwifi | grep Version

That should show the same version that you just installed.

Then you should be fine.

Seems like it’d be so, but I still don’t have the option to connect to wifi in my Network Connections. Only Ethernet.

You’ve helped me confirm that sys-net recognizes and is attached to the wi-fi adapter. Thank you very much. So, what would be preventing it showing up in Network Connections where connect to wifi?

The firmware-iwlwifi package. Once you’ve installed it in debian-11, shut it down (qvm-shutdown debian-11).
Then shutdown and restart sys-net.

Unfortunately, that’s not giving me wifi options. I’ve even shutdown the computer and restarted. Still no wifi option.

Did you verify the installation was successful?

Within the debian-11 template, yes. Version 20221109-2 which is what I installed.

I found this post which had a similar challenge in that wifi was not appearing in connections…

However, their error stemmed from switching sys-net templates from fedora to debian. I’m having the same issue but on a fresh install and, per the above posts, can see that sys-net is recognizing my wifi network controller but still nothing in Connections. Based on this, I’m guessing there’s a permissions issue still somewhere then?