Wi-Fi networks sometimes disappear on resume

It has happened a few times now when resuming Qubes, that the “Wi-Fi Networks” disappear on resume. I still see the ethernet networks but that’s it. Any ideas how to troubleshoot? I wind up having to reboot. I tried this but it did not help.

1 Like

Do you mean the little (network manager) icon in the system tray?

Yes but the internet at the same time fails to work/connect.

1 Like

Then we’re experiencing the same bug probably. We should report it.

As a quick fix for now, instead of having to reboot the whole system you can just run on a dom0 terminal (XFCE Terminal).

qvm-run sys-net "pkill nm-applet; nm-applet"

The above will run pkill nm-applet; nm-applet on sys-net. Essentially killing the the network manager applet and restarting it.

Just to see if it happens on a specific environment:

  • are you running on i3wm? (If you have no idea, then you’re probably on XFCE – the default)
2 Likes

I will try this next time it happens!

1 Like

It happened for me on both, XFCE and i3. So probably independent of the environment.

1 Like

Did you try ‘sudo systemctl wpa_supplicant.service restart’ ?

That has worked for me on a couple occasions. You could also try it with
‘NetworkManager.service’.

If the above doesn’t work, another work-around to save you from
rebooting your whole machine is to ‘sudo halt’ in the sys-net vm. You
can then start it again from dom0 with ‘qvm-start sys-net’ and Qubes
will automatically link it back up with any dependent vms.

1 Like

I have the same issue where network icons are disappearing at one point, but the wifi and ethernet connection will still work even without icons,

Screenshot_2021-07-04_03-46-14

and like @deeplow said before, it will be back when I apply the following command :

qvm-run sys-net "pkill nm-applet; nm-applet"