Network icon disappeared, now can't connect

When I changed the template for sys-net and sys-firewall to Fedora minimal a while ago, one thing I noticed (aside from quicker booting) was that the networking icon had disappeared from the notification area. This didn’t matter as the system remembered my wifi network and password and has connected without a problem for months, but now I have a new router and don’t know how to connect.

I found this thread which suggests killing the applet in sys-net and restarting, but don’t think it will work as I’ve never had the icon there since changing templates. I could switch back to the old template and see if that works I suppose, but wondered whether anyone else had seen this problem, or whether there is a CLI way of connecting to wifi.

Edit: Yes changing back to the old full-fat template worked. I guess there’s something I need to install in the fedora-minimal so the icon shows.

Try to use the following command in dom0:

qvm-start sys-net

It starts OK but the network applet is still missing. As I mentioned, if I change the template to Fedora-34 it works, so it must be that the applet is missing from my fedora-34-minimal template.

Solved. I reinstalled network-manager-applet in fedora-34-minimal template.

1 Like