Veracrypt and whonix

Hello everyone,
I have been driven mad this afternoon trying to install Veracrypt (VC) in whonix.

I’ll try to remember all that I have done. Which is plenty.

  1. I have managed initially to install VC into my debian template and thence its vms with no problem. I did this by simply using gdebi. No problems.
  2. Now it gets hard.
  3. Before trying to install into my whonix-ws template I created a clone of my anon-whonix vm and have buggered around in successive clones trying to make this happen before I tinkered with my whonix template.
  4. Using the above debian method, gdebi will run, but there is nothing installed.
  5. So I have tried downloading the installer (tar.bz2) and the deb package and installing by not using gdebi. No luck.

I am aware of this post: Installing Veracrypt For qubes-whonix and I installed the dependency like so:

sudo apt install libwxgtk3.0-gtk3-dev

No luck. But if I type veracrypt in the terminal VC after these install attempts VC will launch. But it doesn’t appear in the qube settings. And it disappears if the VM is shutdown and then restarted.

I found another suggestion that I need to run the installation in xterm which I did with no luck.

It appears that this error message below that I consistently get may be at the heart of the matter:

user@host:~/QubesIncoming/Browsing-Clearnet$ ./veracrypt-1.25.9-setup-gui-x64
Verifying archive integrity...  100%   All good.
Uncompressing VeraCrypt 1.25.9 Installer  100%  
Warning: Missing charsets in String to FontSet conversion
Warning: Missing charsets in String to FontSet conversion
Warning: Missing charsets in String to FontSet conversion
xterm: cannot load font "-misc-fixed-medium-r-semicondensed--13-120-75-75-c-60-iso10646-1"

I found another suggestion in a red hat forum with these workarounds:

Workaround 1:
Use a different locale
LANG=C xload

Workaround 2:
Edit /usr/share/X11/locale/en_US.UTF-8/XLC_LOCALE and comment out
fs6 {
charset {
name KOI8-R:GR
font {
primary KOI8-R:GR

This didn’t work.

I am pretty much searched out with this. I really haven’t got a clue what to do.

Everything is up to date etc.

I have used whonix plenty but in virtualbox exclusively. I am only now starting to use whonix in the qubes setting and I have had no problem installing VC before. I have managed to configure everything else in whonix so far that I wanted such as bleachbit, nitrokey etc without a hitch.

In my tiredness am I missing something obvious? Anybody got any tips that may help me?

Thanks for reading. I hope that I have covered all of what I have tried. I think so.

Love linux.

1 Like


After getting help for another issue I have managed to solve this problem.

I had the veracrypt deb folder copied into my “downloads” folder, which as far as I know is in the “home” folder but for some reason installing with root privileges did not allow for persistence. I moved the deb package up one level so it sat in the “home” folder with “documents” “downloads” etc. Install from there with gdebi from the terminal (sudo gdebi “veracrypt.deb”) solved this issue. It has one quirk still in that veracrypt shows in qubes settings > applications in app vms created from the ws-16 template but it doesn’t appear like this in the template but the gui launches from the terminal. This is most likely down to me which I am still investigating.

I only put this “solved” here in case some other noob happens to make this error and they can find my post and fix it.

I appreciate the help I get here. I’m not a slacker and I do try my best to solve things before posting, often for weeks because I am aware of questions that waste time. I’m doing what I can.

I’ve only ever used qubes casually but now its my daily driver and I can’t believe I didn’t use it earlier. But with more use comes more questions and learning more about qubes is where I’m at.

1 Like