Using nvidia drivers in dom0

The official guide for doing this is pretty bad and I do not trust it. I tried it and decided I didn’t feel like copying the files over to dom0. Also for some reason it’s using yum.
I Asked chatgpt how to do this, and this is what it gave me. Will this work?

In Qubes 4.2, switching to NVIDIA drivers involves the following steps:

sudo qubes-dom0-update kernel-devel


sudo dnf install gcc make

sudo sh

sudo dracut --force

sudo grub2-mkconfig -o /boot/grub2/grub.cfg

blacklist nouveau
options nouveau modeset=0

sudo dracut --force

sudo reboot

can someone make an updated guide?

I dont have a suitable system to test this on.
Can someone who has provide working notes? @ssssss, that could be you.

I never presume to speak for the Qubes team.
When I comment in the Forum I speak for myself.

1 Like

my 175hz monitor doesnt work with the default drivers. also im wondering if nvidia drivers will improve input latency.

could someone please help

the qubes team should buy some high refresh rate monitors (60+) and achieve compatibility on base Qubes. Currently certain/all high-refresh monitors dont work and I think this is a very big deal for Qubes. Some people find it really hard to use a system on 60hz. Qubes needs to take this seriously. Overall Qubes should work on improving input latency, which includes support for high refresh rate monitors up to 540hz

That might be more about the capabilities of the video card than the drivers. Always good to check. My system has no issue with high refresh rates.

what hz? @quantum

pretty sure depends on monitor

I tend to believe there is an issue between XFCE and the dedicated Nvidia driver. I spent a lot of time trying to make it working but the driver is not loaded and, yes, I followed the steps available on here, on Qubes webpage, Fedora forums etc…
Nothing worked :frowning:

Based on the latest kernel version(s) someone is working to improve the coverage of Nvidia graphic cards with the nouveau driver but still not there yet.

Check my thread here

The manual installation method from the guide works, I’ve used it with 4.2

XFCE is only a software and is unrelated to kernel modules. There can’t be a conflict between the two.

If you share about the exact issue, we may be able to help you.

can you please create a new post that isnt as ambiguous? the instructions are too ambiguous and I’m OCD about following instructions like that.

for example, “nvidia kernel module sources (left from previous step)”, what is previous step? previous step could imply the step before the manual installation heading.
“kernel-devel package installed”, ambiguous, is this already installed? how do i install?
“gcc, make, etc”, ambiguous? what exactly do i need and how do i install them?

like we all have the same exact dom0, why cant we write a proper detailed guide that correctly outlines each step so we dont impurify dom0.