USB Wifi issue

Hi there i have installed qubes. But wifi doesnt work. On my first install i have not seperated usb and net qubes and wifi card was giving a lot of issues. like freezing sys-net, kernel driver fails and i need to plug out and in again etc…

so i decided to reinstall and seperate it. now when i share the device to sys-net either it crashes or doesnt connect to any wifi. it shows them but doesnt conmect. checked journalctl and the disconnect reason is literally None. i tried to install 8822bu driver but when i first did it it freezed the whole system and i couldnt even login after i installed the driver on the fedora template.

i really dont have any other option to connect to a network

What’s your WiFi adapter model?
Does it work in other Linux OS?

a generic one. chipset is 8822bu checked the networkmanager logs it says association took too long failiting activation

tried to disable mac randomization and doesnt work either.

one other issue is that my mouse lags after a while and i need to plug it in and out once

Try to increase sys-usb memory and/or the number of VCPUs assigned to it.

Did you check if your WiFi adapter works in general Linux systems? Need to know if it’s an issue specific to Qubes OS or to Linux in general.
You can try to boot from some Linux Live USB (e.g. latest Fedora Live) and check if your WiFi adapter will work there.

yes it works. adapter is fine but doesnt connect to any network only on qubes

You can successfully connect to other networks using this WiFi adapter in another Linux OS?
What OS did you try?

i tried ubuntu. i also tried to chanhe sys-net to debian and fedora but same issue on both

i also tried to install drivers on template vm but it messes up the whole template for some reason

thank you for the help bit this is exhausting. i decided not to use qubes for now. i fix one issue and one another pops up.

Did you try to use newer kernel version for your sys-net qube?
You can install latest kernel version from current-testing repository for you qubes in dom0:

sudo qubes-dom0-update --enablerepo=qubes-dom0-current-testing kernel-latest-qubes-vm

Latest kernel version in current-testing repository right now is 6.9.2.

i cant connect internet to qubes in any way besides my wifi card

What kernel version do you have in sys-net?
There is an option to install Qubes OS with kernel-latest 6.7.7 in the Qubes OS installer:

You can try to reinstall the Qubes OS with latest kernel version if you’ve installed it with stable kernel.

You can also download the newer kernel version from some other OS:
Copy it to dom0 using USB disk:

Then install it in dom0:

Or you can try to use kernel installed in VM instead of kernel provided by dom0 if this issue is caused by kernel provided by dom0:

its already latest kernel. thanks for the help. as i said this is taking so much of my time with no way to debug or fix so i will sadly stop using qubes from now. tried every possible scenario and fix but still the same