Usb storage problem

Okay - I located a 4.1.2rc1 installer and did the following:

  • Started the installer (selecting kernel-latest)
  • Inserted a USB-stick to install Qubes on
  • Selected “System - Installation Destination”
  • Selected the USB stick, and clicked Done
  • Selected an passphrase for the drive and clicked “Save passphrase”
  • Clicked “Reclaim space”
  • Clicked “Delete all”
  • Clicked “Reclaim space”

and was back at selecting “Time & Date” + “User Creation”. What happens when you try that?

I’m getting this error, even I erased the disk, the disk is not erased, I formatted the disk 10 times, it seems full again

Right - “failed to save storage configuration” seems to be an anaconda error message - I’ve not had that myself … but Google suggest someting like:

“error checking storage configuration” . I went into the setup and set the system reserve partition through the centos installer to standard partition and then mounted it with /boot/efi. I did not reformat it and I still got the same results. As this was puzzling me, I started thinking if this had something to do with the Secure Boot. :roll: Turns out it had to do with the settings of the CSM (Compatability Support Module). The launch CSM was set to Enabled so I switched it to “AUTO”. The message “error checking storage configuration” went away and I am now able to continue with the installation.

is that by any chance related to you machine?

I will try it, thank you very much for your interest, with love from turkey :heart:



To do so, follow the below steps. (Formatting the disk is not needed.)

it didn’t work

1 Like


after delete all partitions.
Save the changes made: type w then enter.
Then reboot.

I’ve updated the missing step.

If you contact me on my telegram address, I can send you a video.

telegram : jack_walter0

The fdisk method should works.
Did you try again with the w command before rebooting ?

I cleaned the disk but it still won’t accept

Where are that disk. oO

You should have answer that question earlier. :wink:

  • Storage: 32 GB free space

Maybe that the problem ?

Is the “SanDisk Cruiser Blade” - by any chance - the USB you are installing Qubes from and not the place where you want to install it (a 500G drive)?

I’m going to buy a new usb and test it.
Thank you for your help
I’ve never seen such a helpful forum in my life I’m amazed :heart:

When I installed on my laptop I wanted, basically, to split the SSD in half. Qubes on one partition, empty space on the other. (I could thus mount it while running Qubes and use it for (sort of) “offline” storage. It has some veracrypt containers on it.)

There didn’t seem to be any way to do that in the installer. You were given the choice of blowing away the whole SSD and installing qubes on the whole thing, OR taking over a pre-existing partition. The SSD was “blank” already, but there was no way to tell the installer to just use half of it.

So ultimately I just plugged the SSD into another system, set it up as two partitions, and then brought it back to the laptop and let the Qubes Installer “reclaim” one of them.

The installer in essence doesn’t include any sort of partitioning functionality beyond “take the whole drive” (and that’s likely due to space constraints, or development time constraints), but it’s not obvious from the name “reclaim space” that it can’t do that sort of thing. I spent hours trying to figure out how to get it to do something that it was (in retrospect, clearly) never intended to do. Basically all it can do is either: take over an existing partition or take over the whole drive; it can’t make new partitions smaller than the drive.

The installer offers exactly this functionality - you can manually delete
partitions and create them as you wish
Select the installation device, and drive you want to install to.
Under Storage Configuration, select Custom option.
Delete and Create partitions as you will, allocating them to mount

I vaguely remember trying to use that and having the “main” part of the installer refuse to accept it for some reason. Or otherwise being hopelessly confused because it was assuming knowledge I didn’t have of what Qubes “wants” its partitions to be like. Unfortunately, it was long enough ago that I can’t remember what the issue was.

It was user belligerent enough that I just gave up on it. I just took my disk elsewhere, created the two partitions, brought it back and gave Qubes one of the two and let it subdivide as it pleased. (I didn’t give any mount point to the other partition; that’s done by the VM I attach it to.)

Well, I cant comment then.
All Qubes needs is a partition for /boot, and a partition for / -
(by default it’s crypto_LUKS)

1 Like

As I think about it, all I was trying to do was make sure Qubes didn’t take the whole disk. So I specified two partitions, but then Qubes apparently wanted to use one for /boot and one for /

I couldn’t just tell it: OK, Qubes, please just take half of the disk and leave the other half alone. Or if I could, there was no obvious way how. [edit: The custom option seemed to me at the time designed solely to let you change how Qubes is laid out on the disk, not to let you restrict qubes as a whole to just part of the disk.]

Further up this thread people were complaining about how hard it was to use “reclaim space” having to go in twice to do things and so on. I remember one time being unable to find options and the next time I could. Whether it was just unclear labeling or obscure positioning or something else (like personal senility) I couldn’t say now. I remember writing a post about my troubles but I cannot find it now. It would have been less than two months ago.