Update error: Jinja variable 'dict object' has no attribute 'os'

I tried updating over systray icon and in qube manager. I also set the default-dvm to fedora 32. It does not fix my update problem.

What does this problem mean? Is this related to saltstack updating via dvm?

fedora32:

Updating fedora-32

fedora-32:
- Rendering SLS ‘base:update.qubes-vm’ failed: Jinja variable ‘dict object’ has no attribute ‘os’

This has come up before Fedora-32 update will not complete

Same error when trying to update debian-11 from qubes-update-gui.

I’ve given up on using the cog wheel update widget, other than to update any non-fedora 32 VM’s. It seems to be a never ending battle of it works, it doesn’t work, etc. For fedora 32 updates I just use the
Qube Manager program, start up the fedora 32 based templates and then update them with the blue down arrow update button. When Qubes 4.1 is released, I will install from scratch and see if the update cog wheel method works. Other problems as well, which I’m hoping a new install of 4.1 will fix.

I’m on 4.0.3 by the way with all updates current.