Fedora-32 update will not complete

For the last couple of days I have been unable to update my fedora-32 template. The “updates available” button in the top menu is continually present, although each attempt to update results in the error message below:

fedora-32: Rendering SLS ‘base:update.qubes-vm’ failed: Jinja variable ‘dict object’ has no attribute ‘os’

This qubes system is just a few days old. After replacing the cpu and mobo, I couldn’t use the old installation. So I reinstalled qubes 4.0.3 and then restored vm’s from the backup. All seemed fine at first and the fedora-32 template and vm’s would update successfully. But not any longer for some reason. Is there something that will get me going on the right track? I don’t understand the error message. Many thanks.

Hi @Qubesquark,
try an update from Qube Manager, right clic on the fedora-32 TemplateVM, Update qube.
See also the 5791 and 5919 closed issues, and this mailing-list thread.

1 Like

Hi ludovic; Your suggestion worked perfectly. 450 MB worth of updates done, including an update of kernel 5.8.14 to 5.8.18. The top menu Update button has disappeared also. Back on track - many thanks!

Unfortunately I’ve had to uncheck the “Solved” box, as the fedora-32 updates are again producing the error message listed in the op. I am now successfully updating, using ludovic’s suggestion via the Qube Manager update route, when I see the notification of available updates in the top panel “Update” button. I can do this until Qubes 4.1.1 is released officially. As an aside, the Debian and Whonix templates do successfully update with the button.

In case the information is of any use to anyone, I should report, that the update widget method (Salt?) started working seemingly on it’s own again yesterday. Remedied by an update via the Qubes Manager, Update method possibly. The widget method had been unuseable for updating both the debian-10 and fedora-32 templates for some time previously. Back to normal and will remark this thread solved.

2 Likes