Unable to install / Black screen (Intel Iris XE)


Yesterday I received my new laptop (Lenovo E15 G2 / i7-1165G2 / GPU: Intel Iris XE / 16G RAM

I’ve done some Qubes installes on other devices, but this one is relentlessly resisting all workarounds I’ve tried.

When booting from USB drive, the usual “wall of text” scrolls over the screen and finally gets stuck at

“Xen is relenquishing vga cosole”

then the text vanishes top down leaving a blank black screen with no changes in hours.

Last lines of text (sorry for the play-button… had to record a little clip because the text was scrolling too fast for a picture):

I’ve tried all troubleshooting tips at UEFI Troubleshooting | Qubes OS so far. Either with no change in behavior or (when changing to options=console=none) getting stuck after the first few lines here:

Xen 4.8.5-29.fc25 (c/s ) EFI loader
Using configuration file ‘BOOTX64.cfg’
vmlinuz: 0x0000000051323000-0x00000000519fe760
initrd.img: 0x000000004fef8000-0x000000005132235c

I’ve tried 4.0.3 and 4.0.4rc so far, both no success.

Also tried with no success: disabling hyperthreading, alternative flashing methods of the ISO to USB drive, using different USB-Drives, connected external screen, tested installation with Debian10 (no issues with the install here)

UEFI can’t be deactivated in BIOS (duh :roll_eyes: )

So maybe one of you can help me out here.

Thank you in advance!

Hi @stetin,

I fear that this graphic card is too recent… Do you know the minimal required Linux kernel for this card?

In the forum, I see install failures with this new intel card.

Search for Linux user feedbacks for your laptop (or near) on linux-hardware.org.

hey @ludovic

yes, I think that’s the problem. I figured out Debian doesn’t like it either. The installation process goes just fine, but no desktop environment would start. (latest ubuntu works fine with though… but who wants to run ubuntu?)

I’ll return the laptop today. Maybe I try to get the first E15 model … it seems to be fine according to the HCL.