Unable to install 4.1.0 - udev error while assigning device slot ID

After reading about successful Ryzen 9 5950X on B550, I built a similar system but am unable to get very far.

I went with 5950X on the MSI MPG B550 Carbon Wifi. I don’t see any MSI B550s on the compatibility list but figured I would try.

I’ve tried legacy and UEFI but am not able to get very far.

With UEFI, I’m able to get as far as a loop about a job start for udev and then an error while assigning device slot ID and then failing to start systemd-udev-settle service. I have a hunch it’s an issue initializing the USB controller because I lose the keyboard about the same time that I hit that udev job start section.

I’ve added a separate pcie usb controller but I still lose keyboard at the same point even when only using that controller.

Just to make sure it wasn’t an issue with the USB thumb drive, I also tried installing via DVD but my DVD drive is an external USB drive so that doesn’t really help much if it is because I’m losing USB completely.

Anyone have any troubleshooting recommendations?

Abandoning as mobo incompatible. Swapping to ASUS ProArt Creator board from compatible hardware report.

I had the same issue with a different board, for anyone else with this issue the cause is amd pushing a gimped bios. As of this post AGESA V2 PI is the latest release and is the latest that works.

1 Like

Thanks for this @n87, downgrading to a BIOS with AGESA works as expected.
Tested on a B550 and X570 motherboard… AGESA V2 PI through all seem to have the USB issue.

As seen here No possibility to enter disk password after BIOS update I have the same problem. Updated by BIOS of my X470 MSI Motherboard and now can not boot anymore into an previous working Qubes OS installation. My current BIOS has the AGESA V2 PI

Is there any workaround?

downgrade your BIOS