Unable to Connect to Internet: No Wireless or Ethernet Card in my Qubes OS

Hello, this is my first time using Qubes OS.

I have been trying to connect to my wifi wirelessly and with an ethernet cable. I have researched and I believe the problem is that I have no wireless/wifi card.

On the panel, when I hover over the network symbol, it pops up a bar that reads “No network conection”, and when I click it my only option is "VPN Connections > " and I see no wifi options. When I connect my ethernet, nothing changes.
I went into sys-net “Qube settings” and added the application “Settings” so it could be visible, and I opened it, saw the option for “network” but no wifi or plugged in ethernet show up there.

I have read that I should downgrade to a previous version of kernel so that the wireless card might appear and work, I tried it. However, it didn’t install because I have no internet in the first place.

I know that I don’t have a wireless card because I ran “lsusb” in dom0 and there wasn’t a wireless card there, and from Qube manager, I know that my sys-net doesn’t have a ethernet card as well. (when installing, I selected the option to allow sys-net control network as well as usb, so I think that wasn’t the issue)

I am trying to install Qubes r4.0.4 to see if this version will allow internet connection while I figure out what do to on r4.1.0

Could I possibly download Qubes kernel 4.19 on a drive and transfer it to my Qubes OS r4.1.0 packages to see if this will allow me an internet connection? Or should I try something else?

In “sys-net” settings, do you have any PCI attached to it?

Hello DVM, thanks for your reply

The advanced tab on my “sys-net” settings, under “Virtualization” it says does say “… no PCI passthrough” and in bold below the mode it reads “PVH mode is hidden since it doesn’t support PCI passthrough”

Can you go in the “Devices” tab and tell me if you have something in the “Selected” list?

1 Like

In the"devices" tab, it says at the top in bold “To modify PCI devices, you must first shut down the qube”

under selected list there is one item: “03:00.0 Network controller: Broadcom Inc. and su”- it doesn’t allow me to scroll to read the rest. The whole page in the devices tab is like grayed out and I can’t do anything here.

Since sys-net is started you can’t change anything. Can you tell me if you get any error message coming up when sys-net start? Like a PCI related error message or anything?

No error message at all when I open sys-net

Do Qubes 4.0 works? It seems like you want to copy a certain kernel version to Qubes 4.1, so I suppose it works on the old version right?

I haven’t used 4.0, I just installed it but I need to finish configuration.
From researching, I believe that the issue is the kernel version, but I don’t know for sure.

Should I go ahead and configure 4.0 to see if I have success?

If it doesn’t work with 4.1, then I don’t really think it will on 4.0. I was just curious to know.
Did you install the 4.1 version or the new one (4.1.1-rc1) ?

I installed the 4.1.0 version because it is a stable release

Give a try to the 4.1.1 version, it comes with the 5.15 kernel and fedora 36 by default, which will have newer firmware that will maybe fix your issue.

Don’t worry about the “testing release” banner, if you install the 4.1 one and do all the updates, you will have the exact same thing at the end.

I thought my issue was that the new Qubes 4.1 kernel was too new and didn’t work with my device for some reason(which is why I was trying to install kernel 4.19), are u thinking that the Qubes 4.1.0 kernel isn’t new enough?

Newer versions should better handle your hardware anyway, so I think it’s a good idea to give the 4.1.1-rc1 version a go.

How about your computer spec?

Hello 51lieal,

On my device(not Qubes) it says: 4 GB 1600 MHz

I’ll give a try, thanks for your help!

I mean your whole pc specs if it desktop, you can tell your motherboard, processor, wifi card and etc. If it was laptop, what the model.

Sorry, I wasn’t sure what specs is.
This is the model: MacBook Air (13-inch, Early 2015)

So I tried 4.1.1 rc1 but I had the same issue as with 4.1.0
However, with 4.0.4 when I click the network connection symbol on the panel, it reads
"Ethernet Network
device not managed
VPN Connections > "

which is more than what showed up in r4.1 so I think something in 4.0 is compatible with my device, I’m assuming it’s the kernel. However, when I plug in my ethernet cable it does not show up, perhaps because I use a adapter(I don’t have a ethernet port, so I use a usb adapter)

You also mentioned something about PCI, do you think this might be my issue, since I’m not sure I have PCI attached.

@51lieal , Do you believe my device isn’t compatible with Qubes OS or this version of Qubes?