Unable to complete configuration on new 4.2 install

Hi, I’m trying to install v4.2 onto a 128GB USB3.2 stick on my Asus ROG i7 laptop.
It worked great with v4.1.1 but this new version installs, and after first boot configuration toward the end it gives me this error:

[‘/usr/bin/qvm-start’,‘sys-firewall’] failed;
stdout: “”
sterr: “Start failed: internal error: libxenlight failed to create new domain ‘sys-firewall’, see /var/log/libvirt/libxl-driver.log for details”

So I’ve re-verified my install usb every way possible, I’ve tryed to install it 3 times now with different settings on the config screen after boot, all virt settings are turned on in bios, but nothing helps. The install doesn’t complete. It gives me the gui after I press ok, but only sys-net is running and No apps are found in any qube – missing. The log file mentioned doesnt give me any valuable info that I can make sense of … kinda frustrating, please help!

Post the logs form dom0:

journalctl > journalctl.log

Or search for errors/failures there and post them.

Ok I got the logs on my google drive here if that’s ok:

What’s the output of this command in dom0 terminal for your disk where Qubes OS is installed?

sudo fdisk -l

Maybe it’s a problem with sector size:

Wow, lots of disks in that list! I added it to the google folder, including my ‘mount’ output if that’s any help, but my booted usb disk is listed as /dev/sdb. I dont see any errors reported there
( QubesLogs – Google Drive )
btw, ya I cant access my gui any more–there’s no menu bar only mouse, I gotto do Ctrl-Alt-F3 to get a terminal

Your issue is not about sector size.
Can you upload these logs as well?


Yea I uploaded my whole var/log dir there, it should be in there

Your USB drive is very slow, the sys-net start time is 7 minutes.
Try to run sys-firewall after sys-net is fully started.
Then again I’m not sure if this slow drive speed could break something and this is why there is no apps etc.

Hmm, ok I noticed the bootup being super slow but I though it was due to some background errors.
True I used a different usb for v4.1.1 but otherwise this usb amazed me with super rw speed transferring files in windows. I also benchmarked it in windows at ~100-120mb/s (at least I think it was mb :slight_smile: ok maybe I’ll try a different usb and see if it makes a diff

is there a script I can run to redo the first-boot configuration?
(would like to see if I could run it with sys-net already started)
Oh, could the 7m sys-net startup have anything to do with me unplugging the ethernet the last time I installed it?

Something like running:

sudo /usr/libexec/initial-setup/initial-setup-graphical

in dom0? – check the path … I found it in an old post about Qubes OS 4.1 (IIRC) …

That looks like it could be what I’m looking for, I’ll give it a try, thanks!

Well! What-do-ya-know! A different usb boot device made all the difference!
I had a 128GB microSD card kicking around and used a USB adapter where I tried installing Qubes onto. The initial install amazed me for taking about a 1/4 of the usual time, but the after-boot config took its time. Anyway, it completed nicely, and the system is running smoothly now!
Thank you guys very much for your help and quick responses! Much Appreciated!

No idea why that was the case though, using it in windows formatted as NTFS was a blaze! It seemed like the fastest usb stick I owned, but I guess using it with an encrypted ext4 drive it didn’t like that too much. Maybe that’s why I got a bargain price for it…well to think that’s all it was… Thanks for your time and info though!