Trying to install to Intel NUC

I saw someone has installed successfully to an intell NUC. I download the latest image on Sunday 31/1/2021

I checked the SHA-256 matched and that it was correctly signed based on the signature download from three certificate servers.

I tried and it failed even to boot let alone install.

I took a photo as the diagnostics wizzed by unfortunately I missed the far right of the screen.
Below is a copy from that photo of the diagnostics and the far right is marked… where it is missing.
These long lines can be identified because they continue on the next line in the log.

Can someone tell me what is wrong. I presume I need to change some EUFI BIOS settings to get this install to work. I am currently trying to use the dynamic power settings to be as efficient as possible.

Or are these signs of a more sinister problem.

Are there any instructions somewhere for installing on an Intel NUC?

ACPI: Invalid sleep control/status register data: 0:0x8: 0x3 0:0x8:0x3
ACPI: 32/64X FACS address mismatch in FADT 6f1b0000/0000000000000000, using 32
IOAPIC[0]: apic_id 2, version 32, address 0xfec00000, GSI 0-119
Enabling APIC mode: Phys. Using 1 I/O APICs
Switched to APIC driver x2apic_cluster.
xstate: size: 0x440 and states: 0x1f
Unrecognised CPU model 0xa6 - assuming not reprpoline safe
Unrecognised CPU model 0xa6 - assuming vulnerable to lazyFPU
Speculative mitigation facilities:

Compiled-in support: INDIRECT_THUNK
Xen settings: BTI-Thunk JMP, SPEC_CTRL: IBRS+ SSBD-, Other: IBPB
XPTI (64-bit PV only): Dom0 disabled, domU disabled
PV L1TF shadowing: Dom0 disabled, DomU disabled
Using scheduler: SMP Credit Scheduler (credit)
Platform timer is 23.999MHz HPET
Detected 1608.088 MHz processor.
Unknown cachability for MFNS 0xa0-0xff, assuming UC
Unknown cachability for MFNS 0x78800-0x7cfff, assuming UC
Initing memory sharing.> CPU0: No irq handler for vector 6c (IRQ -2147483648, LAPIC)
Intel VT-d iommu 0 supported page sizes: 4kb, 3MB, 1GB.
Intel VT-d iommu 1 supported page sizes: 4kb, 3MB, 1GB.
Intel VT-d snoop Control not enabled.
Intel VT-d Dom0 DAM passthrough not enabled.
Intel VT-d Queued Invalidation enabled.
Intel VT-d interupt mapping enabled.
Intel VT-d Posted interupt not enabled.
Intel VT-d Shared EPT tables enabled.
I/O Virtualisation enabled

  • Dom0 mode: relaxed
    Interupt remapping enabled
    → Using old ACK method
    …MP-BIOS bug: 8254 timer not connected to IO-APIC
    CPU0: No irq handler for vector e7 (IRQ -8)
    IRQ7 a=0001[0001,0000] v=60[ffffffff] t=IO-APIC-edge s=00000002
    failed :(.

Panic on CPU 0:
IO-APIC + timer doesn’t work! Boot with apic_verbosity=debug and send a report.
with the ‘noapic’ option

Reboot in five seconds…

It’s a bug (or missing code?) in Xen, fixed in 4.14.1.
See my comment (with patch) on Github: On Intel chipsets from Skylake/ApolloLake (e.g. NUC10i3FNK)


1 Like

Hello Hans,
I’m having this issue on a DELL XPS 13 9380 with an i7-8565U with WhiskeyLake Graphics.
I don’t have Qubes OS currently installed so I can’t even get the installer to work so I cannot even apply this Xen patch you are talking about.
From reading the github thread I understand that I should build my own Qubes ISO with the patched xen but I’m afraid this will be too complicated for me to handle.
Could you explain to me what steps should I follow in order to get Qubes OS 4.0.4 working?

It’s still quite new to me so I think others better give a good answer.

I tried to build a 4.0.4 using Qubes, but got stuck on some compile and link errors. (the dom0 build wants fedora-25 and I removed it already)

In any case it looks like a catch-22: you need Qubes-OS to build it.
Maybe it can be done on Fedora but the documentation is for Qubes.

I also looked at updating the Qubes 4.0.4 ISO directly, but I guess it won’t install when I modify the
Packages/x/xen-hypervisor-4.8.5-30.fc25.x86_64.rpm without properly signing it.

I do not see a Xen 4.14.1 update on GitHub qubes-vmm-xen, yet.

When can we expect a fix?
( . . . and a back port to 4.0 )

Maybe I’ll try later, but I’m busy with something else at the moment.


1 Like

So basically I need Qubes OS to build a Qubes OS 4.0.4 ISO with the xen updated to version 4.14.1?
On the changelog they state version 4.14.1 is “unstable” and that it has medium priority so it doesn’t look like they are fixing this soon. At least not in the next 4.1 version. So it’s either waiting for 1 or 2 years or doing this on your own…
Thanks for the info, might give it a try when I feel like I wanna suffer.

I guess there’ll soon be more and more owners of recent Intel hardware, so I’m quite optimistic.

The latest 4.1 is from October: see Qubes FTP iso repository

Qubes-R4.1.0-alpha20201014-x86_64.iso 14-Oct-2020 11:32 5493489664

Found someone publishing test ISOs: Updating R4.1 test iso

Check the testing-4-1 discussion

1 Like

I’ve tried the latest test ISO from Index of /qubes/iso/ :

24-Apr-2021 04:53

At least it starts the installer on my NUC10i3FNK ( NUC10i3FNB main board).
Maybe I’ll try a fresh install later today or tomorrow.

So it was fixed in development in version 4.1 already in io-apic issues on install boot for 4.1 NUC10i5FNH #6372.


1 Like

Update on:

24-Apr-2021 04:53

For 4.1 I’ve added another 48GB lvm volume + a 512MB boot partition.

I did not get beyond the left column of setup items, because it restarted the installer after some time. Time and Date settings was greyed (disabled) and reported (something like) ‘resetting system time’. Found several out-of-memory errors in dmesg reporting python3 as the cause.

iwlwifi did not work, according to dmesg, but I have a 1Gbps ethernet, so it should not be a blocker.

Intel iwlwifi for my hardware should be available from kernel 5.7 and Qubes 4.1 is running 5.10, so I’d expect it to work. Is the Intel firmware not included by default?


You fixed my problem.
Now I have Ubuntu, Windows 10 and QubesOS on the same 1TB SSD.
Everything seems to work fine, I have sound and wifi.
To install it with Multiboot I just selected the SSD and Custom partition. Then in the custom partition I clicked “automatic partitioning” which detected the free space available on the SSD and created the right partitions there without overwriting other OS data.
I also tried installing Qubes OS on a 32GB USB but it appeared to be too small for Qubes.
My only concern is that when installing you are informed that this Qubes OS is in alpha so you shouldn’t use it outside of testing. So I guess when Qubes 4.1 is finally released I will have to delete everything and install it again. Still it’s nice to be able to use it.

Is the Intel firmware not included by default?

I’m sorry but I don’t think I can help you with this kernel issues, you seem to have much more knowledge than I do.