Error when booting form qubes iso (xps 13 9380)

I am getting these errors when I boot from my qubes iso. I have tried using different drives, verified iso downloads, changing bios settings. I cant really find anything about setting apic_verbosity=debug, which someone suggested doing. Any help appreciated.

See info on apic_verbosity. I think you could set this option by using the kernel parameters.

Also, please describe your hardware (laptop/desktop model, CPU).

I’ll look at that thanks. Its an xps 13 9380 with an i7 8565u. I am editing anaconda/efi/boot/bootx64.cfg but I cant figure what boot entry to add apic_verbosity=dugbug under. I also tried adding noacpi and apci=no and nothing changed.

By default you’ll see this in the BOOTX64.cfg of the installer:



options=console=vga efi=attr=uc
kernel=vmlinuz inst.stage2=hd:LABEL=Qubes-R4.0.3-x86_64 i915.alpha_support=1

You’ll want to add to the options= line of the qubes-verbose section, so that you have:

options=console=vga efi=attr=uc apic_verbosity=debug

Thanks. I added that but nothing seemed to changed when I booted. Does that log somewhere, or am I doing it wrong? I also tried noapic

(@spacetime this sounds like a hardware specific issue, I’ve added the model to the title and moved it to the "Hardware Support " category)

I have learned that dell disables internal legacy boot, so uefi is my only option, but that is where I get the above errors when I boot from the install drive. I tried adding the debug line suggested above but it changed nothing. Would really appreciate any help

Hi and welcome !
So I have a Dell xps 13 7390 and the exact same thing happens when I try to install Qubes os 4.0. The problem is not coming from the kernel but Xen itself. You will probably have to wait for Qubes 4.1 to expect installing it on the xps. But you may try something:

Boot in the bios and under power management look for an option called “Block sleep S3” enable it and boot the installer.

You can also try to play with the different APIC Xen parameter, here is some good documentation about it (what they do in the grub you have to do it in BOOTX64.cfg):

Thanks for the reply! I don’t have an option for block sleep s3 and I’ll look into the xen documentation. So do you understand what this apic timer stuff is that seems to be causing the issue?

So APIC is related to interrupts, that means that when your cpu is occupied an interruption will tell it to stop what it’s doing and do some tasks. For example ps2 mouse and keyboard uses interrupts where usb mouse and keyboard doesn’t. That means the latter have to wait for the cpu to finish it’s task before it does something else. So APIC deals with these stuff. Now I can’t tell you more because that’s all I know, I guess the Xen version in Qubes is too old for the new APIC of our devices. I hope it helps.

Gotcha thanks! So from your understanding this isn’t something we can get past with this qubes version?

Someone linked me this thread because I’m having the same issue.
From what I’ve read this Xen issue can be patched but you have to build your own Qubes OS ISO and update Xen to version 4.14.1 where this bug has been patched.
Also it appears that this patch may cause other issues in other architectures so it won’t be included in Qubes 4.1 which mean we’ll have to wait a long time if we want the devs to fix it for us.
Qubes OS buildind issues

I was able to install Qubes in an XPS 13 9380, see this post