Trying to build a Qubes ISO on Fedora 36. When I get to running "build iso" it immediately fails. .

I’m following the instructions here:

My build environment is a fresh Fedora 36 instance (I installed Fedora entirely to build Qubes on the laptop I intend to run Qubes on. . . I can’t just use the regular Qubes ISO. . . I’m encountering this issue:

Anyway, every time I follow the instructions to the point of running “build iso” it immediately fails with

“make[1]: *** qubes-src/installer-qubes-os: No such file or directory. Stop.”

This seems like a kind of. . . weird thing to not get built. Am I missing some critical step? What might be going on here?

Troubleshooting steps I’ve tried:

  • Building with different templates selected in ./setup (sometimes these fail to build for other reasons, but when they succeed they fail with the same error).
  • Messing about in builder.conf (maybe I don’t know what I’m looking for).
  • Trying to read the Makefile and suss out what it’s doing (the error references line 523. That line is just an @echo, but the line before it “iso.clean-repos:” which seams likely to be relevant and some grepping / googling leads me to believe it’s looking for kernels and kernel install options).

These instructions do seem to be for an older version of Qubes (they reference choosing fc30 in Template Distribution Selection in ./setup. . . the oldest fc available in the current menu is 33). Do they perhaps need updating?