Transfer folders files dom0 to my appVm And folder wallpapper myappvm to dom0

hello, could you help me please, I am new to qubes os, I had made several screenshots, I find them in the (pictures) folder of dom0, I want to transfer or copy all the jpg screenshots that are in dom0 to my appvm which is called Chocolat-Vm, could you give me the command to do on the terminal, is on which terminal to enter the command, that of dom0 or that of chocolat-Vm thank you my version qubes os 4.1

I did a lot of research and I found half of the answer for transferring from dom0 to appVM, however I still have the problem of transferring my wallpapper folder which is in my vmchocolat Pictures/ walpapper from my appvmchocolat to dom0, I found these, but I don’t know what to change in the order?

qvm-run --pass-io <src-vm> 'cat /path/to/file_in_src_domain' > /path/to/file_name_in_dom0

The instructions you mention are for files only. So you can e.g. tar folders and use them on the tar archive.

Btw it’s made so hard that you don’t accidentally compromise your dom0 e.g. via some wallpaper with some additional code inside. ^^

P.S.: Using qvm-convert-img on the wallpapers first inside a disposable VM should reduce the risk.

Does qvm-copy-to-vm work?

qvm-copy-to-vm Chocolat-Vm image.jpg

qvm-copy-to-vm works for dom0 → VM. The instructions you mentioned eaerlier are for VM → dom0.

If you intend to move just a few wallpapers from a qube to Dom0, the most secure way is to display them in the qube in fullscreen and take a screenshot with the screenshot tool from Dom0. Pretty painless and it ensures that all you get into Dom0 is a rendering of the wallpaper and nothing else (no code comes with it). If it’s hundreds of them (why would you need hundreds of wallpapers anyway?), then the qvm-convert-img command should help.

1 Like

could you tell me the command to do? the complete command, I am not used to linux I am new, for that I specify you, the name of my virtual machine Chocolate-VM the folder in which I have my wallpapper is WallpeppEr, could you give me the complete command to introduce in terminal to transfer the file. thank you very much see you

hello triple and how to use this qvm-convert-img command? I don’t understand, can you give me the complete command to enter?

qvm-convert-img [input image] [more trusted output image]

See man qvm-convert-img.

Whenever this topic come up, (and it does very often), I point out the
existence of qvm-get-image in dom0.
qvm-get-tinted-image allows you to apply a color filter to the image
before importing it to dom0.

1 Like

thank you for trying to help me, but as i told you, i am new to linux, so what is the complete command to introduce in my case? is this sudo qvm-get-imagein Chocolat-VM, or qvm-get-imagein Chocolat-VM/home/pictures/walpapper, or qvm-get-imagein /dom0/, or qvm-convert-img /dom0 please could you give me the complete command in my case? name of my vm= chocolate-Vm wallpappEr folder is in picture of my vm,

[user@dom0 ~]$ qvm-get-image --help
usage: qvm-get-image [-h] VMNAME SRC DST

Secure copy of images between virtual machines

positional arguments:
  VMNAME      Source VM
  SRC         Path inside source VM
  DST         Destination path in this VM

optional arguments:
  -h, --help  show this help message and exit

Both SRC and DST may specify format in ImageMagick(1) way, i.e. png:aqq.gif

hello thank you, I tried but it gives me an error and I don’t know where is my error? qvm-get-image Chocolat-Vm ‘cat /home/user/pictures/image1.jpg’ > /home/love/Music/image1.jpg

i have this message

usage: qvm-get-image [-h] VMNAME SRC DST
qvm-get-image: error: the following arguments are required: DST

and when I introduce
qvm-get-image Chocolat-Vm ‘cat /home/user/pictures/image1.jpg’ > /home/love/Music/

i have this message

bash: /home/love/Music: Is a directory

qvm-get-image Chocolat-Vm /home/user/pictures/image1.jpg /home/love/Music/image1.jpg

hello thank you very much for answering me, I introduced the command you just gave me, but it does not work, I believe that the problem is linked to another problem that I am trying to solve, update problem, when i update sudo qubes-dom0-update it gives me,

python3-xen.x86_64                         2001:4.14.5-5.fc32                      qubes-dom0-cached
xen.x86_64                                 2001:4.14.5-5.fc32                      qubes-dom0-cached
xen-hypervisor.x86_64                      2001:4.14.5-5.fc32                      qubes-dom0-cached
xen-libs.x86_64                            2001:4.14.5-5.fc32                      qubes-dom0-cached
xen-licenses.x86_64                        2001:4.14.5-5.fc32                      qubes-dom0-cached
xen-runtime.x86_64                         2001:4.14.5-5.fc32                      qubes-dom0-cached
Dependencies resolved.
====================================================================================================
 Package                Architecture   Version                      Repository                 Size
====================================================================================================
Upgrading:
 python3-xen            x86_64         2001:4.14.5-5.fc32           qubes-dom0-cached          60 k
 xen                    x86_64         2001:4.14.5-5.fc32           qubes-dom0-cached          20 k
 xen-hypervisor         x86_64         2001:4.14.5-5.fc32           qubes-dom0-cached         7.7 M
 xen-libs               x86_64         2001:4.14.5-5.fc32           qubes-dom0-cached         624 k
 xen-licenses           x86_64         2001:4.14.5-5.fc32           qubes-dom0-cached          32 k
 xen-runtime            x86_64         2001:4.14.5-5.fc32           qubes-dom0-cached          19 M

Transaction Summary
====================================================================================================
Upgrade  6 Packages

Total size: 27 M



Total size: 27 M
Is this ok [y/N]: y
Downloading Packages:
Running transaction check
Transaction check succeeded.
Running transaction test
Error: Transaction test error:
  installing package xen-hypervisor-2001:4.14.5-5.fc32.x86_64 needs 236KB on the /boot/efi filesystem

Error Summary
-------------
Disk Requirements:
   At least 1MB more space needed on the /boot/efi filesystem.

I spent a whole day looking for the solution, I can’t find it :face_with_head_bandage:

Edit from @ludovic : I fixed the very ugly syntax

What error are you getting? Or how exactly it doesn’t work?

hello tzwcfq, when I enter the command I have this error

Traceback (most recent call last):
File “/usr/bin/qvm-get-image”, line 49, in
main()
File “/usr/bin/qvm-get-image”, line 46, in main
qubesimgconverter.Image.get_from_vm(vm, args.src).save(args.dst)
File “/usr/lib/python3.8/site-packages/qubesimgconverter/init.py”, line 281, in get_from_vm
img = cls.get_from_stream(p.stdout, **kwargs)
File “/usr/lib/python3.8/site-packages/qubesimgconverter/init.py”, line 196, in get_from_stream
raise ValueError(‘No icon received’)
ValueError: No icon received
[love@dom0 ~]$

Most probably you’ve specified incorrect SRC path for the command. Check the source image path in your Chocolat-Vm.

yes it’s correct, thank you again, yes I have the same error, I also found where the problem comes from, it comes from the fact Upper Lowercase, instead of qvm-get-image Chocolat-Vm /home/user/pictures/image1.jpg /home/love/Music/image1.jpg

its

qvm-get-image Chocolat-Vm /home/user/Pictures/image1.jpg /home/love/Music/image1.jpg

Pictures P

:kissing_heart: :kissing_heart: :hugs: thank youuuu