Touchpad Natural Scrolling?

I did a search but was unable to find the answer to this.

I have 4.1.1 installed on an old Dell Inspiron 7586. At the moment it only has 8GB of ram but I’ll be buying and installing a couple of 16GB sticks later today so I have enough ram to create and run Windows 10 HVM to use for updating certain devices that can only be done in Windows or Mac (primarily map updates on Garmin watches). I’ve tried running Garmin Express via Wine in the past and it just doesn’t work for me.

Anyway, to the point, I can’t find any way to enable natural scrolling here. I tried the XFCE Settings in the main menu but it has no effect and the XFCE settings in the various Qubes don’t even offer the option of reverse scrolling.

I can live with it if I have to, but I’d really like to get that working if it’s possible.


In dom0, try to add Option "NaturalScrolling" "True" to /usr/share/X11/xorg.conf.d/40-libinput.conf

You will have multiple blocks, add that line to touchpad like this:

Section "InputClass"
        Identifier "libinput touchpad catchall"
        MatchIsTouchpad "on"
        MatchDevicePath "/dev/input/event*"
        Driver "libinput"
        Option "NaturalScrolling" "True"

Log off and log back in after editing.

1 Like

Of course! I don’t know why I didn’t think of that. Exactly what I always needed to do with my Slackware installs. Brain fart. I guess I’m getting old.

Thanks a lot, that did the trick.

1 Like