Thinkpad T480 gets pretty hot and battery barely lasts

Hi!

First off let me start off by thanking the Qubes OS project for kicking off this discourse group, Google stuff is making me sick.

Now I have a Thinkpad T480 and I’ve been using Qubes OS with it since the first day that I bought it with.

The only problems I’m experiencing now is that after nearly 1 year of usage the laptop overheats quiet a lot and battery usage barely lasts (1hr with the internal battery).

Is this only fixable if gpu passthrough is established (and what’s the progress on it)? Or are there any tips to help with battery life and cpu usage? (For info I’m just using the usual Qubes install, usually have 3 debian VMs running)

1 Like

Welcome :slight_smile:

I have a thinkpad X1 carbon (gen 5) and the battery lasts 2-3 hours max with average 10 VMs running (with archlinux it used to last 13h). So Qubes is pretty demanding in terms of battery life from what I’ve experienced.

In my case the only things that significantly degrade more the lifetime is watching videos (the fan blasts) and for some reason when I use the Tor browser (but only sometimes).

For info I’m just using the usual Qubes install, usually have 3 debian VMs running

Have you tracked down which process in these VMs is responsible for the high cpu usage?

I’ve had some limited luck using TLP and Powertop, and making sure to notify running VMs of the power stat so they can also go into a more conservative state. (There’s a couple of threads on the old google groups about this, though to be honest I’m not sure how much any of it actually helped).

For the T480 specifically you can also work around the problem with the large secondary battery (it’s a little bulkier but totally worth getting 6+ hrs and all the Qubes goodness)

This may be related to this known issue involving thinkpad battery threshold

A post was split to a new topic: TorBrowser high cpu usage while idle, in whonix

In my case the only things that significantly degrade more the lifetime is watching videos (the fan blasts)

For watching videos in VMs, unfortunately software decoding uses a lot of cpu, but I’ve found these help a lot:

  • disable hardware acceleration in the browser
  • mpv --profile=sw-fast --vo=x11
  • use streamlink to view streams in mpv instead of the browser
2 Likes