Tor Browser high CPU usage while idle, in Whonix-ws

Yes there’s some Tor Browser bug with Whonix that causes CPU usage to spike for no reason. Hopefully it will get fixed with the new Tor Browser alpha.

See the Whonix thread: https://forums.whonix.org/t/torbrowser-8-0-high-cpu-usage-while-idle-in-whonix/5875/19

1 Like

Thanks a lot!

1 Like

This is also very prevalent after a suspend. All Whonix VM’s often start running at ~50-60% CPU until their windows are closed. They will resume their high CPU usage after I open programs again.

So just to confirm, in your case this affects both sys-whonix and anon-whonix (or other whonix VMs you have)?

I should have specified Whonix Workstations only.

1 Like

I just tested the latest Tor Browser alpha which is based on Firefox ESR 78 on a whonix-ws based VM. Unfortunately the issue is still present.

set extensions.torbutton.display_circuit to false

ref: https://trac.torproject.org/projects/tor/ticket/8560#comment:26

1 Like

Just wanted to say that after a couple days of testing, I can confirm that a once-regular problem has gone away forever. I tried other methods and this is the one that worked. Thank you!

1 Like

More details and Whonix-specific information:

http://www.dds6qkxpwdeubwucdiaord2xgbbeyds25rbsgr73tbfpqpt4a6vjwsyd.onion/wiki/Tor_Browser#Tor_Browser_Consumes_100.25_CPU_after_Clock_Sync_or_Suspend.2FResume

Sometimes that works but there are many times where I still get 100% despite setting that option when I first launch the tor-browser.

I will keep trying for the rest of the week and see if the problem persists or if that solves it completely.

Edit: As suspected, problem is still happening even with the Tor Browser 10.