The network icon is no longer displayed

I was following the support I was receiving here and now the network icon that used to appear in the top right corner of the screen is no longer visible. Can i somehow restore it to its original state?

When I start terminal in sys-net , error massage has occurred.

I have the same symptoms as this person. It is possible that I have been hacked. When I try to back up the text file, I get an error and cannot start it.

Also, when trying to plug in the USB and select a mount location, nothing is displayed anymore.

The policy editor has also stopped working. I may have to give up and reinstall QubesOS.

sudo dracut -vf --regenerate-all

After trying this command, AppVM and others stopped standing up, and Qubes Global Config also stopped standing up. I hope I can at least rescue the files…

Can you write down all the commands that you run or other changes that you did in dom0 from the last time when everything worked?
Maybe check the dom0 terminal history.

1 Like

I was typing the commands in bad shape, so it may be difficult to list them all,

sudo NetworkManager

After typing this, I got a vmlinuz error and AppVM wouldn’t start, trying to restore it,

sudo dracut -vf --regenerate-all

I was typing this command here, but then the Qubes Global Config screen went wrong. But when I woke up today and checked it, it was back to the original state.

In the meantime, I’m trying to rescue the vault text file. Can I somehow undo the vmlinuz and recover AppVM? Or can I use commands on the dom0 side to move data from vault to usb.

Which Qubes version are you using?

1 Like

Thanks. Is there a screen or command I can look up somewhere? I had the latest version of RC ready to install this summer, I think it was rc3, or rc2, I’m fuzzy there.

PS: There it is, in the Global config, it is listed as rc4.2.0-rc4.

Steps to fix it:

  1. Go to the sys-net VM settings
  2. Go to devices
  3. Make sure the ethernet controller is in the right field
  4. Click “Configure strict reset for PCI devices”
  5. Select the ethernet controller and click ok
  6. Click apply

Note that this might cause a leak according to the wiki:


Do not require PCI device to be reset before attaching it to another VM. This may leak usage data even without malicious intent!

1 Like

Check Qubes Manager → About = Qubes release ???

1 Like

Okay, that’s a different starting point, since you are using a test release.

Qubes OS 4.2.0-rc4 has only been available since 13.10.2023. So you can’t use it since summer 2023. Can you try a complete reinstallation of Qubes OS 4.2.0-rc4?

1 Like

I have tried PCI and Ethernet reset but it remains the same.

Yes, I know that eventually I will have to reinstall. rc4, for example, is it possible to put the iso on the usb and update from there? I know it’s first of all impossible, but let me check just in case.


Please use the original instructions How to upgrade to Qubes 4.2 | Qubes OS for an in-place upgrade to 4.2. An upgrade with a USB stick is currently not possible, you have to do a clean installation.

1 Like

Umm, is it still not possible? If so, I would like to save just the text files that are now left in vault, but can’t I move them using the qvm command?

You can try backing up your “Vault” via the Qubes Manager → Qubes Manager → Backup

How big is your “Vault” in MiB?

1 Like

I didn’t know there was such a function, the vault size seems to be 43.2 GiB, but I think the storage capacity is OK because I have a 256 GB USB memory stick and another M.2 with 512 GB.I’ll try to back up now.

In-place upgrades are for people who want to go from 4.1 to 4.2 without reinstalling. In this case, it’s possible to use the 4.2-rc4 ISO to install the system and then upgrade all packages to be even with the rc5 that came out a few days ago.

1 Like

I have successfully made a backup! I have copied it to a USB stick for now, but I would like to check the files inside. What application can I use to open them?

Also note:

  • Test restore your backup. Follow the restore procedure, selecting Verify backup integrity, do not restore the data. This step is optional but strongly recommended. A backup is useless if you can’t restore your data from it, and you can’t be sure that your backup is good until you try to restore.
1 Like