System freeze with Lenovo Thinkpad T560 Intel Graphics

Happy new year!!! to all.
Please help me if you can with the following issue.
I have bought specially for QubesOS a Lenovo Thinkpad T series laptop as recommended. I have targeted a T530 and I ended up with:
Lenovo Thinkpad T560 (20FJS03M00), Bios N1KET50W (1.37) 11/20/2020, I7 6600U Processor, 32 GB RAM, 500 SSD Samsung EVO and with integrated Intel HD Graphics 520 / Skylake-U GT2

Unfortunately after installation of Qubes OS the system is just freezing after short time I’m starting it.
The time is randomly, sometimes take hours other times minutes until is freezing.
I have tested also with other Linux distributions (Ubuntu 20.04.1 LTS , Tails OS bootable usb). Both of them are behaving in the same way “system is freezing after a period of time”. Ubuntu is more stable, Tails is freezing very quickly.
When it is freezing any key I press or combination is not showing any reaction.
I have tested the hardware (cpu, ram, gpu) with various tools (occt, metestx86…etc).
The laptop is working fine with Windows 10, not freezing no error.
I understand by searching on internet that there is an issue with the kernel or latest kernels and the Skylake Intel Integrated Graphics.
I did not spend to much time to search for an workaround on Ubuntu or Tails (even if on Tails I have tried few things which did not worked), this is because my target for this laptop was Qubes OS.
I have tried both stable 4.0.3 and test vesion 4.0.4-rc1 both with the same behavior.
I have also a ThinkPad T420 which works fine with QubesOS from this point of view but this one does not meet the Qubes OS requirements and I have other issues with that one. Therefore I have invested in this T560 which I cant use it properly for the moment.

Please help me if you have any idea of how can I solve this freezing issue. I don’t know where to start from since it is using Xen …

Thank you in advanced.

Hi all,
I think I have found an workaround for this issue.
Shortly …disable in BIOS the CPU Power Management (which enable or disables the power saving feature that stop the microprocessor clock automatically when there are no system activities ) fixed the system freezing issue.

Is the BIOS CPU Power Management supported by Qubes OS?

As for information, as mention in previous post, I have the same ‘error’ behavior with Ubuntu (16.04.7 (LTS) , 20.04 LTS) and Tails OS. Windows 10 is working fine with that parameter enabled. I did not tested with Centos or Fedora.

Initially I thought it was related to Intel integrated graphics because the logs are flooded with this messages:
/var/log/anaconda/syslog:2329:19:47:46,211 ERR kernel:[ 40.358767] [drm:gen8_de_irq_handler [i915]] ERROR Fault errors on pipe A: 0x00000080

Then I thought it was because of the wireless adapter because I have the following messages:

/var/log/anaconda/syslog:834:19:47:40,398 WARNING kernel:[ 29.709704] platform regulatory.0: Direct firmware load for regulatory.db failed with error -2
/var/log/anaconda/syslog:835:19:47:40,398 INFO kernel:[ 29.709705] cfg80211: failed to load regulatory.db
/var/log/anaconda/syslog:850:19:47:40,398 WARNING kernel:[ 29.841133] iwlwifi 0000:04:00.0: Direct firmware load for iwlwifi-8000C-36.ucode failed with error -2

Then I thought it was because of the Samsung EVO SSD drive. Tested also with a SanDisk Ultra, but no improvements.

But in the end it was because of the CPU Power Management :slight_smile:
Best regards,

The exact same experience as you was seen on a T460 I once used to test Qubes R4.1; here are some notes:

As you discovered, disabling Intel SpeedStep in the BIOS fixed the lag, but there was still lots of IOMMU journal spam with the i915 driver, unless iommu=no-igfx was part of the kernel command line. With those tweaks the machine was fine (wifi too), but since Qubes disables hyperthreading, it reduced the machine to 2 threads which further hampered performance, so it no longer has Qubes. If you continue to debug, please keep updating!

Hi icequbes1,
Thank you for information. After update the domu0 those errors (i915 / iwlwifi) are gone.
Im using Qubes 4.0.4-rc1, I dont know how it is with the stable version (4.0.3).
However the wireless network is connecting automatically only if in the configuration is changed for the “Wi-Fi\Device” parameter to use the MAC address and not the wifi name (e.g. wl6) as default set it. This is because Device name is changing after restart from wl6 to e.g. wl7.
Just for information for others using the same laptop model, my BIOS settings are:
UEFI Secure Boot = OFF ; Total Graphic Memory = 512 ; Intel Speed Step Technology = Enabled; CPU Power Management = Disable ; Intel Hyper-Trading Technology = Enabled; Intel AMT Control = Disabled; Security Cip Selection = DiscretT (TPM 1.2); Intel TXT Feature = Enabled; Intel Virtualization Technology = Enabled; Intel VT-d Feature = Enabled; Intel SGX Control = Software Controlled

Thank you for support.

I do not remember having issue with the wifi, it “just worked” so I’m unable to say anything more on that, other than I typically use the kernel-latest packages.

Qubes 4.0.4-rc1 is the same as a 4.0.3 system that is up to date - R4.0 is the stable version of Qubes OS. R4.1 is in an alpha state and has not been officially released/published (though signed builds from the Qubes team are available).

Your experience has at least confirmed power management/Intel SpeedStep is an issue on R4.0 and R4.1.