Dell 7490 Freezing after latest Dom0 upgrade to Kernel 5.4


Adding my feedback/experience on new 5.4 kernel in dom0. Not sure this is right place as only just joined forum


  • Kernel 5.4 causes my “Daily” and “Backup” PC’s to freeze.
  • Have discounted hardware issues (checked and reseated/swapped DDR RAM)
  • Disabling “C-States” setting in BIOS solves issue in my “backup” laptop. Could not find any BIOS settings that would solve in for my “Daily use” laptop.
  • Would welcome guidance on what else to explore.


Have been using Qubes as my main OS for over two years. More than happy with it. THANK YOU. It’s installed on two laptops

Daily Use: Dell E7490 laptop : i5: 32 GB RAM : R4.0.3 + upgrades : often running 15-25 AppVM’s
Backup : Dell E6420 laptop : i5: 16 GB RAM : R4.0.3 + upgrades : essential subset of AppVM’s

TemplateVM’s are based on Fedora-32 and Debian-10

I upgrade Templates as soon as updates are available.

Last Thursday I updated dom0 on the E7490 using standard upgrade process (sudo qubes-dom0-update). Main change => Kernel upgraded from 4.19.155-1.pvops.x86_64 to 5.4.88-1.x86_64

After rebooting, the laptop would randomly freeze within 30 seconds to 3 minutes. Sometimes it would freeze during the startup sequence (before sys-net and sys-usb etc had started), other times I could complete user login but screen would freeze as soon as I touched curser and very rarely I could get about 3 minutes of use out of it before it would freeze,… so overall pretty random and have to power cycle laptop to recover.

Switched out NVMe drive, installed R4.0.4 rc2 and got same result with Kernel 5.4.90-1.

Checked and reseated all DDR rams.

Switched to reserve PC (E6420) => upgraded dom0 => found same issue.

This post suggested disabling CPU management settings in BIOS to solve similar issue on Lenovo laptop. OP found it also solved similar problem of screen freezing when running Tails and Ubuntu Live from USB sticks,… encouraging as I had same problem with Tails on my E6420.

Dell BIOS has two sections influencing CPU management, (“Performance” and “Power Management”), with a combined 11 options. The “Performance” Section has 5 options:-

  • Multicore support
  • Intel Speedstep
  • C-States Control
  • Intel TurboBoost
  • HyperThread Control)

…Testing: … hours of… boot => mod BIOS => reboot into Qubes => sigh => repeat…


E6420: BIOS ver A25

  • Disabling “C-state Control” option fixed the issue. Is able to run Kernel 5.4.xx without freezing
  • Bonus: Tails and Ubunutu Live USB sticks now work on this laptop with C-State Contol disabled.

E7490: BIOS ver 1.17

  • Disabling “C-State Control” had no impact. => extensive testing of other BIOS options could not resolve laptop freezing when running 5.4.88-1 and 5.4.90-1 kernals.

Any (constructive) Suggestions
Q: Would welcome any other suggestions on how to explore machine freezing with latest dom0 stable kernal (5.4.xx ).

Q: Is there any significance/clue in the name change of the kernel?
(4.19.155-1.pvops.x86_64 => 5.4.88-1.x86_64). … ie pvops? …(ps… this is what grasping at straws looks like!)

Hi @knotty ,

I haven’t a solution but directions to explore.

  • monitor the temperatures (CPU, Motherboard, disk)
  • analyze the kernel traces (maybe some errors before the freeze, kernel module traces, firmware loading traces)
  • keep a terminal always viewable with below commands and hope to get a valuable trace on freeze
    • the dom0 logs (sudo dmesg -Tw)
    • the xen logs (loop on xl dmesg? Who know a better way?)
  • Search the hardware support for your Latitude 7490 laptop from linux-hardware
  • your laptops are common models, continue to search for similar issues on OS distribution forums
  • see the kernel parameters related to your hardware (dangerous if you don’t understand what you do :boom: )

Another idea, switch to a more recent kernel. But do it only if you understand what you do (:boom:) and after a fresh backup. Carefully read the dom0 kernel-upgrade, and try the kernel-latest (5.10.8).

@ludovic Thank you for taking time to reply.
Clearly I have some reading and more work to do.

Will update this post with what is found out and how things progress.

Thanks again.

The same freeze happens on my laptop Thinkpad X260 16gb RAM after the latest kernel upgrade. The weirdest thing is that it freezes when I start personal domain only. After reboot it works normally. I shut down the laptop and when I started personal domain freezes again. After reboot works normally. :face_with_raised_eyebrow:

We have recently been working with Qubes and the Dell Latitude 7490. After many setbacks we were able to get the OS working by using the with Qubes R4.1.0-Alpha20201014 release. Still not 100% complete with setting it all up and wanted to inform the community.

Thanks (belatedly) @BRWells for contributing to the thread.

I can now report that I have solved the problem I was experiencing with R4.0.4 and kernals > 4.19.

This post pointed direction to issue being with power management and Intel integrated graphics with kernels > 4.19.

This link offers more detail of the issue.

Solution for me with Dell 7490:-

  • boot PC from a Linux Live USB
  • Start a terminal
  • sudo su
  • mkdir ./tmp
  • mount /dev/nvme0n1p1 ./tmp
  • nano ./tmp/EFI/qubes/xen.cfg
  • edit to add i915.enable_psr=0 to the kernel parameters line. I added it to all kernel versions listed in the file.
  • Ctrl + X to save and exit … exit “su” and reboot

Have been using now for a week with no freezing GUI’s.

Hope this helps someone else.