Sys-usb for Usb Qubes / Please HELP//

Hello Qubes family,

Usb Qubes; I enabled sys-usb during installation. Installation finished but sys-usb is not active. I have to use an external wifi adapter because my computer has low coverage. I have manually enabled sys-usb but when I start sys-usb my system freezes. I searched a lot, but I couldn’t solve the problem. Please, I would be very grateful if you could teach me how to use usb devices for usb Qubes. thank you best regards

Make sure you assigned the right PCI device to sys-usb (check qvm-pci ls or the preferences GUI).


Does your PC freeze, or does your peripherals stop working? You can check by watching the clock.

Also you do not necessarily need sys-usb for that.
You could use sys-net as sys-usb, or manually assign the USB controller with your external wifi card to sys-net. Take a look at the documentation for this.


Hello, thank you for your response. Actually, as far as I understand, when I check my usb devices, my usb memory where the system is installed and my usb adapter appear on the same location dom0:00_14.0. Is there a way to disconnect the usb device on which I installed my system from my wifi adapter? When I try to start dom0:00_14.0 my system crashes and I can’t do anything. I think the usb stick I installed the system is losing its function…

if you have multiple USB controllers, you could try another one and exclude the one with your main storage from sys-usb. But i am not sure if you can do that, or if you could even use sys-usb at all if booting from an USB stick.

1 Like

My computer has 3x usb ports. I don’t understand why all my devices appear in the same spot… Have you ever witnessed usb devices being used for usb qubes? Or Isn’t there such a feature?

I am not sure what you mean.

I do use some USB devices of course, even some more “exotic” ones that do not work with the block device handling, like printers or micro controllers.

To figure out if you have multiple USB controllers, go into a terminal in dom0 and type in: qvm-pci list | grep USB. Some devices have multiple, but some have only one. If you only have one, you will be unable to use sys-usb.

If not, with this information you can start to figure out what devices are connected to what controller.

1 Like

I’m sorry for not explaining my problem clearly, I’m pretty new to this stuff… I would be very happy if you could help. I see exactly these…

dom0:00_0d.0 USB controller: Intel Corparation Tiger Lake-LP Thunderbold 4 USB Controller
dom0:00_0d.2 USB controller: Intel Corparation Tiger Lake-LP Thunderbold 4 USB NHI #0
dom0:00_14.0 USB controller: Intel Corparation Tiger Lake-LP USB 3.2 Gen 2x1 xHCI Host Controller

qvm-pci attach sys-usb dom0:00_14.0

Make sure no other devices are attached. You can check if other devices are attached to sys-usb by running:
qvm-pci list

Start sys-usb:
qvm-start sys-usb

If you get any errors, let us know.

If you do not get any errors, then proceed to attach your thunderbolt controllers.
If you get any errors after attaching your thunderbolt controllers, please let us know.

1 Like

Hi Thank you for your response, when I check (/sys/bus/usb/devices/usb ) I see all my usb devices are connected to dom0:00_14.0.

Since the usb stick on which my system is installed is connected to dom0:00_14.0, my system becomes inoperable when I start sys-usb. My internal keyboard and touchpad are working but my wireless mouse is not working and the system is not doing anything.

The points I contact redirect to the desktop. just like I removed my usb stick from the computer (I tried this, I took out the usb stick, the result was the same.)

Note: The wifi adapter I use is ALFA AWUS036NHA /Atheros 9271. I run this wifi adapter on the same computer as plug and play in Kali OS.

Hi please help me… @51lieal

  1. Run the following in dom0: Do you see 0 or 1?
$ grep 'hide_all_usb' /etc/default/grub &> /dev/null; echo $?
  1. (a) Run the following in dom0 and paste the output here:
$ qvm-pci list sys-usb

If the pci controllers are the exact same as what you posted in reply #7 proceed to next step, otherwise just reply with the above:

  1. (b)
$ qvm-pci list sys-net

If here you see other controllers beside wifi/eth, stop and let us know.

  1. (c) We need to check if you also have a combined sys-net/usb (but I don’t remember the exact name so the command is a bit messy):
$ qvm-ls | grep net | grep usb

If you see results, stop and let us know.

  1. In dom0 run:
$ qvm-pci detach sys-usb dom0:00_0d.0
$ qvm-pci detach sys-usb dom0:00_0d.2
$ qvm-pci detach sys-usb dom0:00_14.0
$ qvm-pci list sys-usb

If the last command doesn’t produce output, proceed to next point, otherwise disable any remaining controllers

  1. dom0:
$ qvm-start -v sys-usb

Check if everything runs properly. If the system is usable, proceed OTHERWISE paste the error here:

  1. dom0:
$ qvm-shutdown -f --wait sys-usb
$ qvm-pci attach sys-usb dom0:00_0d.0
$ qvm-start -v sys-usb

If the system is usable, repeat point 5 but attach the next pci device, and repeat.

If the system is not usable, detach the pci device and try with the next, AND paste the error here.

This will tell us if you have problems with only one controller or with all of them.

I have PM you.

So you have two TB4 ports and one USB 3.2 port. If your usb devices are all USB-A ones (who have square and big interfaces), then it’s predictable that all of them are connected with the USB 3.2 port. You will need a dock, or an adapter that connects to your PC through one of the TB4 port, offering USB-A ports. You need to split your USB wifi adapter with your system USB stick, so connect one of these two devices to the dock. Then it becomes possible to use sys-usb in your case.