How to use the Alpha AWUS036NHA Atheros 9271 wifi adaptor?

Hello everyone, I’m a beginner qubes user. If your help brings me to the conclusion, I will pay you some BTC as a thank you payment…

I’ve been trying to connect my wifi adapter to qubes for about a week but I couldn’t succeed ( ALFA AWUS036NHA /Atheros 9271 ). I’ve been using it on Kali and a few Linux without any problems.

I see all my usb devices are connected to dom0:00_14.0.
When I enable dom0:00_14.0’ device and start sys-usb, my computer freezes, my internal touchpad and keyboard work, but my computer does not respond to any commands.

What I really want from you is how can I use a usb devices on a computer that uses usb qubes.

My computer has 2X usb host controller.
My computer is a 2022 model Asus.
I am using USB Qubes.

I tried many things but it didn’t work. I have not come across a satisfactory article.

Please HELP

It’s a topic I’ve talked about before. Maybe a tip.

Does your system support iommu and slat?

1 Like

Hello, thanks for your response. I don’t know how can I find out?

I can use my wifi adapter on other linux.

You can find out in your HCL report.

in dom0 terminal type:
qubes-hcl-report ‘name of qube to put report into’

It will print out various stats on your system including iommu and slat support.

Thank you so much

I/M MMU: Active

You could try giving more RAM and disable memory balancing for sys-usb

Memory balancing disabled… 2gb ram.

I also tried the PV Mode…

Maybe try not enabling device through dom0 and just start up sys-usb? Make sure pci devices are connected to sys-usb through the qube settings.

Yes, that’s exactly the problem here. From the pci settings, I choose dom0:00_14.0 to which my wifi adapter is connected. When I start sys-usb my computer is no longer usable…

I can’t see any usb device connected in dom0. I can see my usb stick and microphone… when I control it with qvm-usb, I can see my wifi adapter…

My wifi adapter’s power light doesn’t even turn on…

I’m stumped, it sounds like the problem I have every now and then when usb devices don’t turn on. Hopefully someone else can chime in.

thank you for taking the time. have a nice day

I don’t understand what this means

Note: I changed the title from “USB WIFI ADAPTOR /// Please HELP /// I WILL GIVE BTC AWARD” to “How to use the Alpha AWUS036NHA Atheros 9271 wifi adaptor?”

Please don’t use upper cases but a descriptive title, thanks.

1 Like