Successful Qubes install, now stuck with Freeplane install. Can you help me get started? Please?

Hi all,

First things first: Thank you so much for creating Qubes! I hugely appreciate the immense amounts of time and energy that have been put into this, and continue to be put into it, and I am very grateful that there are capable people in the world who provide me with such a powerful tool.

DEAR MODS I: If I should have sent this to the wrong place, or if I should go about this in a different way, please do tell me. Doing my best in good faith, willing to learn.

DEAR MODS II: This is a re-post of a post that got copied into the qubes-users forum from the Google groups, but that one garbled the formatting, so I’m reposting it here. I would have deleted the other one but seem to have no such option. Apologies!

Qubes beginner here who feels like he’s fairly good at flying a Cessna (Mint) and is now trying to fly a fighter jet… so many additional buttons and switches in this cockpit! Some help would be awesome…

This post got longer than planned, so

HERE IS THE BRIEF VERSION OF THIS POST:

QUESTION: Would you be willing to walk me through the process of installing Freeplane on Qubes / Whonix-Qubes?

DONE SO FAR: Managed successful disable of Intel ME via 1vyrain and then Qubes / Whonix-Qubes install on an X230 i7 with 16 GB RAM and SSD.

NEXT GOAL: I want to install Freeplane and test whether it runs well enough on this machine on Qubes with rather large mindmap files. Freeplane is a deal breaker must-have software for me, so installing and testing it is the first next step I want to focus on. If it helps, I don’t need Freeplane to have net access, actually might even prefer it not to have net access, so maybe a standalone / vault type VM just for Freeplane might make sense. Tried to install it several times, really unsure why I didn’t succeed so far, despite lots of reading and my best efforts. If Freeplane works well, I want to use Qubes as my daily driver as soon as possible. I’m hoping that I’m not delusional to hope that I can learn to do that.

ABOUT ME: 10 years of Linux use (mostly Mint) and converting others to Linux. Have done some programming in the long distant past but not considering myself a programmer. Done occasional command line stuff when a particular need arose, by seeking out and following instructions. Constantly broadening my horizon re security and privacy, and valuing both very much. I understand the value of the compartmentalization approach of Qubes for security and privacy, and have a fairly clear idea how I want to make use of that. Unfortunately I’m still lacking a lot on the practical side, I still need to learn how to actually operate Qubes. In other words, I can probably draw my ideal Qubes diagram without too much trouble, but don’t know how to then actually create that setup. I’m guessing and hoping that my level of skills just about puts me in the “minimum user requirements” range for using Qubes.

Thank you for reading this far, would be great to hear back from you, have a great day!

If you have some more time here are some more details and thoughts, but

FEEL FREE TO SKIP THE REST FROM HERE:

My guess is that if I had someone sitting next to me who knows how to work Qubes, I would probably learn what I need to learn to then continue mostly on my own within an hour or maybe even less.

I find the process of digging through documentation and piecing it together from there extremely slow.

So slow in fact that that alone could become a deal breaker for me for Qubes, because unfortunately, while I have some time that I can dedicate to this, I don’t have unlimited amounts of time.

At the pace I’m currently going it could take me weeks just to be able to actually start using Qubes in real life, but I don’t have weeks because I actually need to be able to use this machine for real purposes very soon.

So either I can learn to at least start using Qubes as my daily driver within a week or two, or I’ll need to shelve Qubes for the time being, and go back to Mint.

I really like Mint, but Qubes is in a completely different league in what it makes possible, so I am definitely motivated to make that switch.

I have the suspicion (and the hope) that this is just an initial barrier that I need to push through, and that with help, this might not necessarily take overly long.

But right now I’m stuck.

The Freeplane install and test is first on the agenda.

If that’s successful, the next goal is to then decide exactly what I want my compartmentalization to look like, and then set things up accordingly - deciding in which way which qubes connect to the net, installing software in various qubes, data storage decisions, etc.

But I would like to focus on step 1 (testing Freeplane) first, and then think about this next.

Yeah so that’s where I’m at at the moment.

Any takers who would like to talk me through the process of installing Freeplane, for a start? Please?

I could really do with some help…

Thank you for reading, keep being awesome, have a peaceful day!

Jack

Welcome to Qubes OS.

In a similar vein, it would be helpful to keep your questions specific and short. There is a separate area for introductions. I’ll be honest, I only glossed over your post.

  1. What have you attempted in regards to installing Freeplane?
  2. Are you receiving any errors?

I recommend you review documentation on installing software.

My thoughts after looking over Freeplane’s website (I haven’t actually tested this or checked in you can just apt-get install it…). There are a lot of ways that you could probably set this up depending on your security model.

  1. Clone the debian-11 template. Call it something like debian-11-freeplan. This is prevent polluting your primary Debian template and makes it easy to experiment.
  2. Open a disposable web browser window
  3. In the disposable web browser, download the Freeplane installation .deb file
  4. After it downloads, you should be able view the downloads folder from the browser. 5. Right-click on the downloaded deb file then select copy or move to other VM
  5. Select your debian-11-freeplane template VM.
  6. After it transfers, open a terminal or console in the Debian template. You can right-click on the VM in the Qubes Manager and select open console in…
  7. Locate the deb file. It should be under /home/user/QubesIncoming/dispNNN.
  8. Install the package with dpkg
  9. Shut down the Debian template VM
  10. Create a VM/qube
  11. Select the Debian Free plane template as the AppVM’s template. Maybe name it Freeplane
  12. Finish any other settings, such as adjusting the visible applications to include Freeplane
  13. Power on the new Freeplane AppVM
  14. Hopefully you should be able to open Freeplane.
1 Like

Hi, thanks for your reply. I’ll try and keep it as short as I can.

I really appreciate the step by step guidance, thank you!

However my problem is that not each step that you list is self explaining to me, not to a degree that I can actually do all steps successfully.

So the best I can think of right now is to go as far as I can in your list, and then tell you exactly where / how I get hung up.

Which is very early, and that’s limitations on my part, obviously. But that’s exactly what I need help with, so I can learn those things that might be completely obvious to you and others here.

I don’t know if that is too much support to ask for. This is not meant in a cynical way at all - I genuinely don’t know.

I do consider myself a fairly capable Linux end user.

Maybe I should have asked first whether Qubes is meant for end users, or just for people who understand Linux in depth?

If the latter is the case then Qubes may not be for me, although that would exclude a huge percentage of the population from potentially being able to learn to use Qubes.

If that’s the case then that’s ok too of course, who am I to tell the developers who to develop software for.

But in that case I should probably stop asking for support and wasting your and other’s time, stop trying to make Qubes work for me, and move on to something that is actually meant for users like me.

Just to be clear, genuinely no judgement from me either way here, I’m not looking for an argument nor am I trying to criticize anyone with this. I just need clarity on this, that’s all. Sorry I didn’t ask this earlier, the question only occurred to me right now.

If you think that it makes sense for me to keep pursuing this, then back to your list of steps, here is where I get hung up right now:

Step 1:

Clone the debian-11 template: Open Qubes Manager, right click debian-11-dvm, select “clone cube”, enter clone name “debian-11-freeplane”, click “ok”. Cube was cloned successfully.

Step 2:

Open a disposable web browser window: Menu - hover “Disposable: whoniex-ws-16-dvm” - select "Tor Browser (AnonDist), the only browser I see here. Tor browser opens, loading web pages works.

Step 3:

The only .deb version of Freeplane 1.10.6 (most recent stable) that I can locate seems to be https://sourceforge.net/projects/freeplane/file/freeplane stable/freeplane_1.10.6u1~upstream-1_all.deb. Download seems to have worked.

Step 4:

Located the file in the downloads folder.

Step 5:

Right click on the downloaded file, select move to other VM; select the debian-11-freeplane template VM. File disappears from downloads folder. Ok.

Step 6:

In Qubes Manager, in debian-11-dvm, start console from within Qubes Manager. The console is now asking me for the debian-11-dvm login. I have no idea what that is. If this is what I need to use, can you please tell me what login to use here? Why is it asking for one?

I realize you said “TERMINAL or console”, so I try to open a terminal in the debian-11 VM: Menu - Template: Debian-11 - debian-11: Terminal. Terminal opens, no issues this time. I hope that’s what you meant. I’ll proceed assuming you did.

I get a warning that debian-11-dvm is running out of space. I use the prompt to go to the VM’s settings and increase space from 10 to 50 GB, wildly guessing a number here.

Step 7:

Locate the .deb file in the terminal. I know I’m missing non GUI skills here. Please help me out. Obviously this terminal is in the Debian VM. I simply don’t know how to navigate to /home/user/QubesIncoming/dispNNN.

So that’s the next step I would appreciate more detailed steps with, if you have the time.

Thank you for bearing with me!

Cheers

Jack

Btw I did go through the document that you linked to before posting here. I just couldn’t make it work. I also worked through the steps suggested by several other sources, which I also didn’t manage to get to work.

Unfortunately I didn’t note down exactly what the issues were, which is why I didn’t try to recount the details of my earlier attempts, it would not have been the best use of everyone’s time. Sorry…

Re-starting from

Step 6:

On further investigation I realized that in step 6, you probably were referring to opening a terminal or console in the debian-11-freeplane template, not the debian-11 template. Correct?

So I tried that, which completes step 6, and then:

Step 7:

In that VM I now am able to locate the downloaded .deb file, because that’s the VM that I actually moved it to. In the incoming folder, just as you said.

Step 8:

Started the install with sudo dpkg --install downloaded_file.deb. Install started. Unpacking finished successfully.

But then stopped with the error message:

“Dependency problems prevent configuration of freeplane: freeplane depends on default-jre and java7-runtime; however: Package default-jre and java7-runtime is not installed.”

I understand this to mean that I need to install Java first, ok. Which I attempted like this:

sudo apt update

java -version

This returned “Command not found” (and nothing else)

sudo apt install default-jre

This returned unmet dependencies on default-jre-headless and openjdk-11-jre and said about both “but it is not going to be installed”.

So I need to install Java, but so far haven’t figured out how to make that work.

Limping along with baby steps…

Read up some more, and

sudo apt-get update

and

sudo apt-get install -f

seem to have resolved this issue, and the Freeplane install process seems to have finished without errors.

Onwards to step 9…

Step 9:

Shut down Debian template VM. I strongly assume you mean debian-11-freeplane here. Done.

Step 10, 11, 12:

Create a AppVM/qube - template is the Freeplane VM. Set some settings for this AppVM that seemed to make sense to me.

Step 13:

Power on new Freeplane AppVM - unfortunately at this point my laptop rebooted. Went to black screen and then reboot instantly when I started up the new AppVM.

At this point I definitely really need help, I have no idea at all where to even start looking what’s going on there.

As before, if you could pick me up from here that would be amazing… I’m really doing my best, even if it may not seem much to you.

Have a nice day, wherever you are!

Jack

So on reboot, unfortunately I enter the disc encryption password, then Qubes begins to start, and a few seconds after, it goes back to the prompt for the disc encryption password.

My guess is I may have shot myself in the foot with some setting in the AppVM that I created.

In any case I regret having ticked the box “start AppVM on boot”. If I had not done that, I would probably be able to boot right now.

If anyone can suggest a way to fix this I’m all ears. If no easy way exists, probably time to reinstall Qubes and redo the Freeplane install.

For the latter I’d still love to know what actually caused this boot issue, so I can hopefully avoid that setting or whatever it was the second time round.

I’ll take a break for a few hours.

Enjoy your day!

H Jack
Sorry you are having issues here.
If you were to use the official Debian package, then you would not be
having a problem. You could simply open a terminal in your cloned
template and run sudo apt install freeplane. This would install
freeplane 1.7 . This is generally the Debian way, but it does mean that
you are working with older versions of software.

I think you may be a little confused about where to install software - it
isn’t easy to get the hang of it.

The first thing to do is to get your Qubes running again.
Without knowing quite what you did, it’s a little difficult to help, but
let’s see what we can do.
When you are booting the x230, interrupt at the grub screen - where you
see the choice to boot Qubes. You’ll see something like “press e to
edit” - press e, scroll down to the line that start “kernel”, and add to
the end of that line qubes.skip_autostart.
Boot using that change - you’ll see on screen how to do this.

Now Qubes should start but no qubes will start.
You should be able to delete the troublesome qube - I would probably
delete everything you have done so far - and then restart.
With luck you Qubes will start as normal.

Now to freeplane.
Clone the debian-11 template to a new template, template-freeplane.
Download (as before) the debian installer, and then copy it to
template-freeplane, just as you did before. (template-freeplane will
automatically start so you can do this.)
Open a terminal in template-freeplane - In the Q menu you should see
xterm or uxterm.
Then run these commands:

sudo su
cd /home/user/QubesIncoming/NAME/
apt install ./freeplane_1.10.6u1~upstream-1_all.deb

replacing NAME with the name of the qube from which you copied the deb
file.
After the install has completed, shutdown the template.

Then you should be able to create a new qube, using the
template-freeplane.
Open a terminal in the new qube, type freeplane, and you should be up
and running.

I find that freeplane may need some extra memory - you can adjust this
in the settings window for the new qube on the Advanced tab.

If you hit a problem at any stage, please make sure you report any
specific error message.

I never presume to speak for the Qubes team. When I comment in the Forum or in the mailing lists I speak for myself.
2 Likes

Hi unman, thanks for chiming in as well, I really appreciate it.

Yes you are right, I am not clear yet on many things in navigating all this.

Very grateful for sm95’s and your help.

I think I’m learning bit by bit, and the obstacles so far haven’t managed to extinguish my excitement for what Qubes can provide if I manage to learn to use it, and if Freeplane runs smoothly enough on an X230 i7, with large mind maps. My mind is still blown that Qubes exists.

Don’t be sorry, I didn’t expect it go to without speed bumps, I can’t expect to fly this metaphorical fighter jet without putting in any work. So far I still see these “detours” as useful insofar as they broaden my horizon, as detours tend to do, and ultimately help me to learn more.

I’m not sure I understand what you mean by the official Debian package, are you referring to the source from which I got the Freeplane .deb file, or to a non Qubes Debian installation?

If it’s the former then I’m not sure where to get a “more official” .deb file than the one I am using right now. I think this is the official source that the Freeplane devs provide.

Ok, I’ll try what you suggested to get Qubes running again:

During startup, I only get a very brief flashing of "Welcome to Grub, it only shows for a fraction of a second, so if I need to act on that in some way to get to the screen that you mean, I don’t know that I have a chance to do that that quickly.

Anyway, at the next screen (although that screen is blue and doesn’t look like the grub screen I know), I can select “Qubes, with Xen hypervisor” or "Advanced options for Qubes (with Xen hypervisor).

However there’s an “[e] Edit Selection” option, so maybe this is the grub screen you meant.

I tried “e” with either of the above options selected.

In either case that gets me into a screen that is titled GNU GRUB version 2.04, and I can edit on that screen.

However the word “kernel” is nowhere to be seen on the entire screen.

So not sure what to do now. Am I in the wrong screen?

I hope this helps you help me - thank you!

Did some digging, realized that you probably meant the line starting with “module2”.

Did as you instructed.

This popped me back to the disc encryption password one more time; and after that, Qubes booted, hooray! Ok we’re back in business and I don’t need to re-install Qubes.

Is this edit that I did in GRUB permanent or only for that one boot? Guess I’ll find out at next boot.

I can see in Qubes Manager that the only thing that has started is dom0. Good.

I deleted everything I have done so far, and brought Qubes back as close to a fresh install state as I think I can. And I have a lot more confidence that I have actually achieved that than I would have for example in Mint.

This right here is already an awesome experience - it’s so easy to erase the mess that I created before in this way. I have a feeling being able to do everything in isolated Qubes will seriously increase my appetite to break stuff going forward.

Good stuff.
The edit you made applies only for that boot.
If you want to make a permanent change you need to set changes in
/etc/default/grub and rebuild grub configuration.

When I talk of “the official Debian package” I mean the package released
by Debian. You can install this from the Debian repositories using apt
or aptitude, and you will have some confidence that it will work as
intended.
This is the Debian way.
The stable release will have older software versions.

That said, the deb package produced by freeplane does install correctly
if you follow the steps I set out.
If you do have any problems, don’t hesitate to ask.

1 Like

Sorry, I was still limited in number of posts a day yesterday, so got interrupted in updating you by that and had to wait to post again.

I am trying to break things up into separate posts for readability, but obviously that algorithm worked against that there :slight_smile:

I hope I can make four more posts after this one today, because I’ve made some progress in the meantime and new questions. I have prewritten them in the meantime, so here goes:

Now back to Freeplane, second attempt.

I can see now that I probably misunderstood several of sm95’s instructions at my first attempt. My bad.

Now following both your and their instructions:

All seems to have installed well, except the last line stating:

“N: Download is performed unsandboxed as root as file ‘/home/user/QubesIncoming/anon-whonix/freeplane_1.10.6u1~upstream-1_all.deb’ couldn’t be accessed by user ‘_apt’. - pkgAcquire::Run (13: Permission denied)”

What does this mean, and how relevant is it?

Anyway, shut down the template next.

Created a new Qube freeplane-app, as an AppVM (correct choice?)

Drum roll… Freeplane starts! Seemingly without issues.

I’ll test drive Freeplane now and see how smoothly it works.

For me, as far as I can see, this is the last make-or-break barrier for Qubes becoming my daily driver.

Thank you both heaps for getting me to this point! I’m not telling you any news here, but I could not have got this far without your help.

So here are the results and observations of my Freeplane testing. It’s a mixed bag, and I hope this can somehow be improved.

I’ll try to describe Freeplane’s behaviour as well as I can, in hopes that that might help you to identify what might be causing it:

When first clicking on any menu entry, the entire app freezes for half a minute. But it appears that once that first menu entry has opened, all other menus work fine and are responsive. Very responsive in fact. If that only happens once at the beginning when I start up Freeplane, that’s fine by me. It almost feels like the menus need to be loaded on first use.

Opening large maps takes a very long time, a couple of minutes or so, on first load of the map. I can live with that, I don’t open mindmaps very often, maybe once or twice a day.

Saving large mindmaps is a bit sluggish, but not a real problem.

During use, overall Freeplane is not quite as responsive as I would like it to be, but that’s probably still manageable. Time would tell whether I can really live with that or not, but I’m optimistic about that part, not concerned here.

But there are severe intermittent freezing issues, and if there is no way to solve those, they are unfortunately a deal breaker for me.

When it works, it works pretty well, quite a bit of the time really well actually. Most of the time I would probably not be bothered by the very slight lack of responsiveness that I mentioned above.

But at seemingly random intervals, and frequently, every two or three minutes, Freeplane freezes up completely, entirely, for anywhere between half a minute up to two minutes or even longer.

The duration of those freezes seems to be slightly correlated to the size and number of mindmaps that I have open. This made me think it might be Freeplane’s auto save, so I disabled that, and that didn’t solve it.

I think the freezes happen particularly often when I scroll or pan into areas of the mindmap that I hadn’t looked at since loading the map / which hadn’t been on the screen since opening the map.

There seems to be an element to it that suggests when I’m working in areas of the mindmap that I’ve been in for a while things are good, and when I go into an area that hasn’t been on the screen for a while, things get really choppy and hang up a lot.

But there’s also an element that seems random about it, it freezes up for half a minute or more apparently randomly. But I can’t see a really clear correlation between any particular actions I take in the app.

I can use other VMs without issues during those freezes, so I think the problem is probably either rooted in Freeplane or in its AppVM.

Whether I only have one very small mindmap open, or half a dozen very big ones, seems to make relatively little difference to the frequency or duration of the freezes.

Whether I work on files that are on a microSD card in the laptop’s card reader or on files that are located directly inside the Freeplane VM also makes little difference.

A look into the task manager shows no issues that stand out to my untrained eye:

CPU 10%, memory 20%, swap 0%.

qubesdb-daemon 9 freeplane-app: 1.9 MiB
qrexec-daemon -q 9 freeplane-app user 1.9 MiB
qubes-guid -N freeplane-app […] var/run/qubes/guid-conf.9 -d9 5.5 MiB
pacat-simple-vchan -l 9 freeplane-app 5.5 MiB
qrexec-daemon -q 9 freeplane-app user 268.0 KiB

By the way, video streaming is not working particularly well on this setup either. 480p works fine. 720 is watchable for a short while but I wouldn’t want to watch a whole movie that way, quite a lot of dropped frames. 1080 is totally useless. When I first download a video and then play it, 720 works pretty ok, 1080 still not good. To be clear: I don’t care. Well, it would be nice if that wasn’t the case, but I can live with it, I don’t need video on this machine. I want this machine for mindmaps, text, and the odd bit of web browsing. So this just as another hint that may or may not help you to determine what the issue is.

Now as to potential causes:

Could this have to do with allocated VM memory maybe, or some other setting or configuration issue? What things could I investigate that might be possible to improve here? Or could there be some Qubes backup progress that tries to run every couple minutes?

Is there any reason to think that maybe installing a full Debian OS in a VM, and installing Freeplane on that, could improve this?

Different Java version, maybe an older one?

Just brainstorming and trying to think about this from different angles that may or may not make sense. I really want this to work. Still clinging to the hope that this can be solved.

But if this can’t be improved substantially, since Freeplane is THE tool that I must be able to use, this is not usable in the real world for me. This behaviour of Freeplane would interrupt my thought processes many hundred times a day, I can’t work like that runs into his trailer and slams the door But seriously, like this, it’s not usable for me unfortunately.

I hope that you or someone else might have a few more tricks up your sleeves that might still make this work properly…

Or is Freeplane for some reason not very compatible with Qubes?

Or is Qubes only likely to work properly on very modern and very powerful hardware? I wouldn’t consider an i7 X230 with 16 GB RAM a complete fossil, regarding performance anyway. But maybe my hope that this would work well enough were misplaced nonetheless.

I don’t really want to believe that an X230 with Qubes on it can only be good for browsing the web, emails, and writing text. Surely it can do more than that? Or is Freeplane THAT demanding in some way or other? I know I’m naive about this, I’m genuinely asking.

Looking forward to hear if you have any further ideas what to try.

If this can’t be made to work well enough then I’ll regret even trying Qubes. I wouldn’t be able to use it, but havig played with it for a bit now, I would forever wish I could.

Have a peaceful day!

Could this have to do with the freezing issue maybe? Just realized.