Successful Qubes install, now stuck with Freeplane install. Can you help me get started? Please?

Could this have to do with my 1vyrain advanced BIOS mod somehow? To do with virtualization?

Or some BIOS setting?

Oh so I wonder if checking RAM in the task manager is actually checking RAM usage of dom0? Should I check RAM usage specifically of the AppVM of Freeplane? How / where?

Another observation: When I copy or paste a larger number of nodes within the same mindmap from one place to another (essentially just editing the mind map, not even saving the map), it freezes for anywhere between fifteen seconds to a minute or so - and the physical hard drive light on the laptop indicates that stuff is being written to the drive.

Does this indicate swap usage?

If that is the case - why is it using swap exactly? The entire file size of the mindmap that I am testing with right now is only 2.7 MB. Why would editing that map, without saving it, cause swap use?

There are two distinct states that Freeplane can be in - in one state things just work well, in the other state it’s frozen up.

Sorry for describing this in quite a bit of detail, just hoping it will help to diagnose and fix what’s going on.

Yeah but sometimes it also freezes when I’m doing nothing but highlighting branches in the map that’s already loaded - so not even panning or zooming, basically just moving from one branch to the next with the cursor keys.

I’ll stop now. I hope some of this might be helpful to help me figure out what’s causing this.

Have a nice day! :slight_smile:

Just found out how to have a closer look at RAM use.

Freeplane VM is using 380 MB
dom0 4080 MB
sys-firewall 3096 MB
sys-net 384 MB
sys-usb 384 MB
sys-whonix 3532 MB
vault 3377 MB

Adds up to 15.16 GB

That’s pretty close to the 16 GB that this laptop has.

If it could accept more I would put more in, but it can’t.

So is this actually just that, memory running out and swap use causing these freezes?

Is there a way to reduce any of those memory uses listed above?

I’ll try to shut down the vault and see if that makes a difference. That should bring total RAM usage down to under 12 GB, which surely should prevent swap usage?

Ok, shut down vault.

sys-firewall went up to 3984 MB
sys-whonix went up to 3984 MB

That seems to indicate that firewall and whonix were using swap already before I shut down vault?

So total RAM usage now is 13.2 GB. That’s a lot considering I’ve only got one single app running and that app is using under 400 MB. But I do understand why Qubes needs a lot of RAM.

I hope that 13 GB is low enough to prevent swap usage now - if that’s what the problem was / is.

Trying to use Freeplane again…

Nothing has changed, the freezing still happens. Could swap still be used despite “only” 13 of 16 GB being required? If so, can I prevent that somehow, and force Freeplane to do everything in RAM only?

I’m taking stabs in the dark here obviously, just trying to make sense of things but with limited knowledge and experience.

I’ll give it a rest for today, not sure what else to look at right now.

I hope you have a good day! :slight_smile:

I’m digging around for possible solutions again:

I’m wondering why it take a full 2 minutes to open a single mind map that is only 15 MB large.

This seems to suggest that drive read speed incredibly slow for some reason. Is that normal on Qubes?

This could explain extremely slow swap as well.

Maybe there is a better driver or something like that?

Do I need to activate some device in the AppVM of Freeplane?

It’s an SSD, so not exactly slow as such, and it the exact same drive worked lighting fast in a normal Mint install before I put Qubes on it. Hm.

Another observation: When Freeplane hangs, CPU use of Freeplane goes up form baically zero to about 20%.

Wow, if I just open Tor Browser, with just one single tab open in it, that uses another additional nearly 3900 MB of RAM, apparently.

I have to ask: Is Qubes realistically possible to run with 16 GB RAM, in a way that it is actually usable?

Is anyone successfully using Qubes for real uses on an X230, or any other machine that can not accept more than 16 GB?

So just Qubes / Whonix-Qubes plus one Tor Browser tab open uses 15.3 GB RAM.

If there is a way to get Qubes to run on 16 GB of RAM then I must be overlooking something that I can do differently that would substantially decrease memory usage.

Wow I just realized that while in Freeplane, every single time I tap an arrow key / cursor key to select a different node in the mindmap to be highlighted (not entiering any text, not editing anything at all in the map, just highlighting a node), the laptop’s hard drive light flashes for a fraction of a second. Every single time.

That can’t be right? Why would the hard drive need to do anything at all for that?

Unless, despite the displayed about 2.5 GB of RAM that are still free, in reality there is zero RAM free anymore, and every tiniest action has to happen in swap on the hard drive?

Is that what is going on here?

Found a 1vyrain advanced BIOS setting to explicitly inform the BIOS that an SSD is installed. Activated that. It seems to have helped a little, but not much.

Seeing just how much RAM Qubes alone consumes, with no apps open, I wonder if it would be a good idea to substantially increase the recommended amount of RAM for Qubes. Personally, from what I can see so far, while 16 GB is enough to run Qubes, it does not really allow one to actually use any apps of any noteworthy size. Just food for thought.

It is possible that I am completely overlooking something here, some way in which I can improve the situation that I am describing in my above posts in a meaningful way.

But I have to admit that I’m starting to lose hope that it will be possible to actually use Qubes in real life on an X230 i7 with 16 GB RAM.

The minimum that I need to be able to do is work on my mindmaps in Freeplane, and have say a dozen browser tabs open; and for both that to work without major amounts of freezing or sluggishness.

So far it doesn’t look to me like that’s possible. I am getting the feeling that I might not be able to use Qubes after all.

Running out of ideas what else I could try to make this work.

Any input on what else I could try very welcome, when you have the time.

I’ll respond to your Freeplane content later, probably in a day or two.

This normal behavior. The standard Qube/VM is configured with a minimum and maximum amount of RAM. Qubes OS defaults to assigning the max amount of RAM then dynamically decreasing Qube RAM as needed.

This is handled by the qmemman service.

To view an individual Qube’s RAM usage, you would need to use a tool running on that Qube to view system resource usage. (You might be able to get this from dom0, but I am less familiar with this aspect.) For example, instead of opening Freeplane in a Qube, select the Run Terminal from the menu and run something like htop.

1 Like

edited

1 Like

I just made a qube with Freeplane 1.11.1-pre28 from their website.

Cloned debian-11 to debian-11-freeplane

In debian-11-freeplane use the command sudo apt install freeplane

Download and copy the 1.11.1-pre28 deb package from the freeplane website to the debian-11-freeplane template.

Install the 1.11.1 with sudo dpkg -i freeplane_1.11.1-pre28_upstream-1_all.deb

Make a appVM with the debian-11-freeplane as template and whonix as netvm.

Start the appVM and from the commandline you can start freeplane with the command freeplane

This worked for me.

1 Like

Thank you sm95, that would be great. I’ll wait.

Btw I may tend to reply quickly, but I am only doing that so anyone who happens to have some time to read my reply and respond to it can do so when they next have the opportunity, not to imply “hey hurry up” or anything!

Also thank you for explaining that RAM management behaviour, that is helpful to know, and now that I know this, it actually makes sense.

So if I understand you correctly, Qubes assigns the maximum amount of RAM to any given VM by default, and only decreases it if and when other VMs need more RAM and thus there isn’t as much left to go around.

If I understand that correctly, the RAM usage display that I get when clicking on the blue Qubes Domains icon at the top right of screen would only tell me how much RAM each Qube is currently using, but would not be meaningful for the purpose of telling how much RAM there really is “left” for opening another additional VM, correct?

So I was using that tool try to get information that it isn’t suitable for, which is useful to know.

Hi @cayce, thank you for joining my little odyssey of figuring this out here!

Yeah I have noticed that Java is a hungry little thing.

If there was a suitable non Java alternative to Freeplane I would definitely prefer that, but there isn’t - not one that has the functionality that Freeplane has, not even close. Paralleled only by a few communication apps in importance, for me, Freeplane is pretty much the most important software that I use. There is no substitute that will do. Believe me, I have tried everything. If you are a power user of mind mapping, Freeplane completely plays in a league of its own.

So I do need to figure out a way to make Freeplane work well.

I have to admit that if RAM is the issue here in my case, and if the X230 would accept more than the 16 GB that I have already put in, I would probably throw more RAM at it as my first response - it can never hurt the machine anyway, and if that would make my problem go away, it would be worth it for me.

Alas I can’t, so yes, troubleshooting it is. Still clinging to some hope…

But does this really sound like a RAM issue to you? I’m not entirely sure anymore.

As @sm95 explained above, Qubes allocates maximum RAM to each Qube as the default, and decreases that to balance things when additional VMs get started that need more RAM.

Knowing that now, and seeing that the Freeplane VM only ever seemed to use 400 to at most 600 MB of RAM, does it really look like this freezing issue is due to lacking RAM?

Also, I have used Freeplane extensively for over ten years, frequently with very (very!) large mindmaps, and it has never been particularly RAM hungry at all, and has in fact been software that has performed extremely reliably as well, for example on Ubuntu or Mint, with 8 GB, on an X200.

What else could it be but RAM? This question is above my pay grade to answer.

I have set initial memory in the Freeplane AppVM to 600 MB, max is 6000 (inherited from its template VM that I created).

I know 6000 is very high, I just wanted to see how much Freeplane would really grab if I let it.

But the Freeplane VM has never used much more than 600 MB.

Doesn’t that suggest that this is not a RAM issue?

@cayce I don’t know if Freeplane is managing heap.

I’ll try manually specifying heap sizes as you described and report back.

Thank you!

@renehoj Thank you for going through the effort of setting up Freeplane yourself, I really appreciate it.

Unless I’m missing something here, that’s pretty much exactly how I have installed Freeplane on my Qubes; with the only difference being that I have usd the stable version.

If you still have it installed, can I ask whether it performs reliably if you keep creating new mindmap branches, typing a bit in them, copy/pasting random branches around in the mind map, etc, for say two or three minutes?

I am asking because at fist I also thought “awesome, Freeplane is sorted”. It started up just fine and everything looked ok, and it felt pretty snappy too. Then I started using it beyond the first few seconds, and after a minute or so the freezes started to happen.

Something you could do to test is create maybe a hundred or so individual branches in the map, simply by copy/pasting to multiply them, or something like that; and then write random stuff in a few different branches for a minute or two.

Can I also ask what the main system specs are of the machine that you have tried this on? Just so I can compare.