Start hold until boot process finishes / Blackscreen or reboot after decryption (Post Install)

After couple of days of troubleshooting and trying everything that the Qubes Forum and documentation had to offer, I finally found the kinda trivial solution (at least in my case) that fixes the following problem which some users face when installing qubes:

After installing Qubes and completing the initial setup, the machine gets a blackscreen / graphical weird looking screen and shuts down / reboots following the LUKS decryption.

The process stops at “start hold until boot process finishes…” (LightDM)

The GUI troubleshooting section in the documentation suggests to add ‘efi=no-rs’ to the xen.cfg file, but this (in my case) didn’t work.

In my case, just a PCI attached device (done automatically with the initial setup?) to sys-net was the problem.

This steps fixed it for me:

  1. Install Qubes normally on your preferred machine, but on an external drive
  2. If you face the issue, boot Qubes (installed on the external drive) on another machine
  3. Deactivate “start automatically on boot” for sys-net
  4. Remove any PCI devices from sys-net
  5. Shutdown and boot again on your preferred machine

Now this particular Qubes installation should work on your machine.

In my case, the cause of the problem was the Wifi card, so you may want to use another one than your current one for Qubes Wifi access.

(I don’t know if this has been mentioned so far anywhere or not, but I just thought it may be helpful for future users who face the issue and maybe find this post via Google, as I couldn’t find any anwser that worked for me, so maybe as an addition to all the other things you could try in case of this issue)

For keywords:
qubes post installation reboot loop
qubes post installation black screen
qubes post installation decryption not loading
qubes start hold until boot process finishes
qubes lightdm hold until boot process finishes

Have you tried, if adding qubes.skip_autostart will allow you to boot on the normal machine and fix it there?


I just tried it out, didn’t work in my case unfortunately, still had to use another machine to de-attach pci devices

Strange - I tried editing the GRUB config, changing the

module2 /vmlinuz-... quiet ...


module2 /vmlinuz-... qubes.skip_autostart ...

and Qubes only started dom0, so I was able to open Q → Qubes Tools → Qubes Manager and add/remove PCI devices for sys-net. Which version of Qubes are you running? – my Q → Qubes Tools → Qubes Global Settings says “Qubes OS 4.1”

1 Like

I’m using Qubes OS 4.1 (4.1.1)

I re-installed once again to try out your clarification (thanks for that!), as I only added qubes.skip_autostart at the end instead of replacing it with quiet. Unfortunately it didn’t work this time too… I guess the problem is that as soon as the initial setup reaches a certain point, it seems that sys-net is starting in the background, causing it to crash, even without a reboot. After that, the issue persists, sys-net (apparently) autostarts after decryption

But I have to mention that I can only modify the GRUB config in /etc/default/grub, because when I add something to GRUB pre-boot, like in the reference you suggested here:

I cannot safe the changes / boot with the changes. The editor key shortcuts in this pre-boot GRUB editor don’t work on my machine for some reason, only the exit ones…

Maybe the place I edit the config is initially the wrong one?

I’ve tried it in two ways:

  1. skip the initial setup, edit the GRUB config in the path I mentioned just with dom0 available and start the initial setup manually from /usr/libexec/initial-setup/initial-setup-graphical without using another machine
  2. Use the OS drive (with both the install and the initial-setup* done on the issue machine) on another system and just change the GRUB config (not doing anything with PCI-devices) to try out your suggestion

*Something I noticed after multiple installs on both the machine where the install works from start to finish and the machine where the issue comes up:
It seems that the initial setup isn’t finished properly on the issue machine, because it reboots/crashes before there is the option to “Finish configuration” is clickable. On the working machine it runs through until I can click that button. I haven’t noticed this so far because the system looks fine, but there has to be something that wasn’t correctly configured/installed because it quit early. This just as a sidenote mention

When skipping initial setup at first and then relaunching it manually, I was able to have the Qube manager open side by side with the initial setup window and apparently there is a short time frame where the sys-net Qube is installed and not yet started, so I was able to quickly detach any PCIs and disable start on boot before sys-net was started as part of the initial setup process, this way I was able to finish the setup completely

Right … I read “(Post Install)” as “Installation completed successfully” … but you are right, that during the installation, the initial setup insists on starting the cubes and that can break the installation process. Sorry for suggesting changes that wasn’t relevant for you situation. :-/

In my case it’s a Lenovo T14 Gen 3 (w. AMD Ryzen 6650U), where I currently need to limit the number of vcpus to 1, in order to have the cubes start - so I know the “Quick! - make the change to the cube, before it’s started”-race with the installer … and I have done test installations on an USB stick in a different machine, in order to work around the initial setup.

For others, I found the process was suggested in:

and the qubes.skip_autostart documented in:

1 Like

No worries! Thank you so much for contributing and making suggestions + showing better solutions which don’t require my workaround for the case of others facing the issue, much appreciated! :slight_smile: