Start failed: internal error: libxenlight failed to create new domain 'sys-firewall'

I have virtualization enable yet when I try to start up the sys-net or the sys-firewall I get this message

Start failed: internal error: libxenlight failed to create new domain 'sys-firewall' '

aswell as sometimes I get a terminal like message from sys-net saying turn probing edd off yet I dont know how. can anyone help?

New to qubes.os

A few questions so that we can help you better:

  1. Are you trying to install the 4.1 release or some other version of qubes?
  2. Do you have both, VT-x and VT-d enabled in the BIOS?
  3. What hardware are you installing Qubes on?

yes, I installed the 4.1 version of qubes.os I just cant seem to connect to the internet at all. im not sure if I have both enabled but I did enable virtualization so when qubes boots I can see the blue screen. and im using qubes on a ryzen 7 3700 and a 6700xt with 32 gb of ddr4 im almost certain thats my specs but I havent checked in awhile and I can’t see now as I am on qubes not my main computer.

If it’s a completely new install of 4.1 with it installed from scratch (and not an upgrade from a different version), the error would be quite unusual (looking at similar error reports from back in the 4.0 rc1, but that’s probably unrelated at this point).

I recommend that you double check that the following settings are enabled in your BIOS:

  1. AMD-v
  2. AMD Nested Page Tables (NPT) (RVI)
  3. AMD-Vi

okay thankyou I will look through my bios now, any idea where to find those sttings within the bios? like advanced etc

Usually advanced but they could be inside of submenus. What motherboard do you have?

I have a gigabyte motherboard it accepts both wifi and ethernet

I’m not sure, but perhaps this video could help: How to enable AMD Ryzen Virtualization on Gigabyte motherboard - YouTube

I enabled that yesterday. restarting now to see if its still enabled or if I have to change it or change any of the other things that you asked me were enabled

im in the bios now and everything looks right, I came across a “IOMMU” setting that was turned to auto but I just changed it to enabled. do you think that couldve been the issue?

Yes, that could have been the issue.

are these the only two I should have in the selected space in the devices tab?

Yes, ethernet and wifi

yeah, im not sure. Everything in my bios looks as should everything is setup as it should be and I still get a message like this.

It could be a xen bug. There used to be a problem with iSCSi devices in the past, but it does not seem to be your case. Do you have another USB drive laying around? You could try installing qubes to that one, instead of your internal hard drive to make sure virtualization settings are correct.

I have a extra hdd I can do it on, are you hinting that the usb may be the problem I only ask that because ive downloaded qubes 3 times on this flashdrive and each time I had the same problem

I also have a vpn on my main system idk if that could be the issue.

No, I was trying to rule out the SATA interface. You could try the other hard drive or install to a different USB drive and see if things work fine. I don’t believe the VPN is a problem.

okay thankyou, I read up on something about disabling the boot manager. do you think that would work before I reinstall? only asking because the reinstall will take around 10 hours or longer so if I can fix this without doing that itll save alot of time.

Hmm, i think you may end up with a bricked system if you do that, so try at your own risk.