Star Labs Star Book MKVI

brand: |
Star Labs
model: |
bios: |
cpu: |
12th Gen Intel(R) Core™ i7-1260P
cpu-short: |
chipset: |
Intel Corporation Device [8086:4621] (rev 02)
chipset-short: |
gpu: |
Intel Corporation Device [8086:46a6] (rev 0c) (prog-if 00 [VGA controller])

gpu-short: |
network: |
Intel Corporation Wi-Fi 6 AX210/AX211/AX411 160MHz (rev 1a)
memory: |
scsi: |

usb: |

  • works:
    qubes: |
    xen: |
    kernel: |
    remark: |
    credit: |
    link: |

1 Like

Suspend doesn’t work.

Not been able to try wifi, camera, microphone

1 Like

Does the bios/firmware support changing suspend from S0ix to S3?

The current version of Qubes doesn’t support the S0ix mode, but it should get fixed in a future release.

I don’t know much about these things but apparently S0ix depends on IME and as Star Books come with IME turned off by default, it must be S3.

What about 6.1 kernel (kernel-latest package)? Suspend does work on MK V.
What’s the exact behavior? Does it go to sleep (but has issues on resume), or doesn’t go to sleep at all?

OK editing this post, managed to update to kernel 6.1 now.

6.0.12 on this machine causes graphics issues but 6.1 seems fine.

Yes, with 6.1 suspend works. The problem was the waking up again after but that’s now fixed.

add --action=update to the command

Thank you, wish I had known that an hour ago but got there in the end.
Yes, with 6.1 suspend works. The problem was the waking up again after but that’s now fixed.

1 Like

@marmarek after a re-install I find that kernel-latest messes up the graphics. Not sure why it worked before. Kernel 5.15 doesn’t have that issue but then suspend doesn’t work so it would be nice to have the latest kernel. Any ideas?

Seems to need

Thank you @sheepskin for your HCL report, which is online now!

Sorry for the delay!

Thank you.
I have been able to test microphone and webcam now (both fine) and have had no problems with either wifi or ethernet. There is a lot of fan noise, which Star Labs have promised to try and fix via a firmware update soon.

how did you fix waking up again on this chipset please?

Editing this: it isn’t working for me with a 6.1 kernel, device goes to sleep but doesn’t wake. (Lenovo X1 Carbon 10th gen )

Can I suggest one change to the HCL Report?
I have the exact same machine, and running “dmesg | grep TPM” shows the following:

[    0.012507] ACPI: TPM2 0x000000007662F000 00004C (v04 COREv4 COREBOOT 00000000 CORE 20221020)
[    0.012543] ACPI: Reserving TPM2 table memory at [mem 0x7662f000-0x7662f04b]
[    0.541442] tpm_tis MSFT0101:00: 2.0 TPM (device-id 0x1B, rev-id 22)

This was done from a Linux Mint environment though, planning to get Qubes OS on this laptop in the near future. So @sheepskin will most likely have to verify using the same command within dom0 to see if it is accessible within Qubes OS. If he can get the same or similar results, might I suggest reflecting this in the HCL?

Here you go

[ 1.134989] ACPI: TPM2 0x0000000076637000 00004C (v04 COREv4 COREBOOT 00000000 CORE 20221020)
[ 1.135069] ACPI: Reserving TPM2 table memory at [mem 0x76637000-0x7663704b]
[ 3.188115] tpm_tis MSFT0101:00: 2.0 TPM (device-id 0x1B, rev-id 22)

Could you advise on how to update to Kernel 6.1? All I’ve found online was how to do it on Debian-based distros. The issue I’m facing is suspend not booting back up. HDMI also is not working and I assume this is an igfx problem. Would I fix this by upgrading to Kernel 6.1? I’m on the Starbook MK VI. Thanks.

If you want to run/test kernel 6.x in dom0, then this should give you the kernel-latest (and that should be 6.x):

sudo qubes-dom0-update --disablerepo=* --enablerepo=qubes-dom0-current-testing kernel-latest


Thanks I ended up figuring out about 5 min before your comment. I appreciate the help.

I’d like to suggest a revision to the “Remark” section for the Star Labs Starbook MK VI. It should be noted that without upgrading to kernel 6.1, the user cannot adjust screen brightness, connect an external monitor via HDMI, or use the suspend/sleep feature (it doesn’t boot back up without full restart). This will save users a lot of time in wondering why the brightness setting doesn’t work, which in my opinion every user will (the full brightness is ridiculously bright)

For anyone looking to use an external monitor via HDMI, adjust screen brightness, and use the sleep feature, upgrade to kernel 6.1+ using:

sudo qubes-dom0-update --enablerepo=qubes-dom0-unstable kernel-latest
1 Like

I used a different command than you to upgrade my kernel. Could you clarify the differecne?

sudo qubes-dom0-update --enablerepo=qubes-dom0-unstable kernel-latest