SSD in WWAN?

Has anyone done this? I’m concerned about the PCI ssd overheating in a T480 if I install Qubes on it. Is there any barrier to installing Qubes in a WWAN slot? I’m considering a 256GB NVME M2 PCI Western Digital S250 in the 2242 size.

Hi @SoPunny. I have actually got a similar question to this. I have an x230 and a T430, both have a WWAN slot which I have an Orico 512GB mSata drive. Your T480 is most likely an M.2 drive instead of a Msata drive but the location is also the WWAN slot. Every time I tried to install Qubes on the mSata drive, I would have issues at the point where Qubes is trying to build the templates. The progress bar would stop and at a certain point, everything is unresponsive. I have tried this on both X230 and T430 and it’s the same. Were you able to install it on the T480?

I haven’t bought one yet so I don’t know. I’ll do some more research and wait for more replies. I know that the Western Digital SN520 2242 works for the T480 for other OS’s though. Do have error logs? That could give us more insight.

This might be related. They’re talking about connecting an external SSD through thunderbolt, but someone said:

The real problem is that dom0 does not support PCI hotplug. The correct approach is probably to enable PCI hotplug, but ensure (using the IOMMU) that DMA is only enabled for whitelisted PCI devices. This ensures that new PCI devices are visible, but cannot attack the system until they are explicitly assigned to a VM.

And another:

And unfortunately PCI hotplug + IOMMU situation in Xen is not great and for this reason we have it disabled. So, the answer for now is “this feature is not supported”, sadly.

I know that the WWAN slot for my thinkpad needs a PCI NVME SSD, whatever that means… Better research more. However, in this thread, people accept that PCI SSDs work.

  1. Is there any difference security-wise between SATA SSD and PCIe SSD?

unman:

I don’t believe there is any significant security issue between SATA and
PCI disks.

Edit: I guess it’s not that relevant to you because you’re using an mSATA or something. Maybe Qubes just has a problem with booting on the WWAN slot regardless of the SSD type.

1 Like

Thanks for the thorough reply @SoPunny. Is there a way to see the error log during an installation, especially one that freezes? If so, I can try to install again and then with the right guidance perhaps I can copy and share the error log.

I haven’t seen any other discussions on the thread regarding WWAN slot only someone from this thread had asked but there was no follow up.

Yes you can! I looked on Github and it’s possible even when there’s a fatal installation error. You can switch to tty2 (some terminal) with Alt+Ctrl+F2. You may want to do that before it reaches the error, but I’ve never tried it myself of course. Try looking at /tmp to find logs. Packaging logs are anaconda.log and packaging.log FYI. Return to GUI mode (tty6 apparently) with Ctrl + Alt + F6.

1 Like

Ok, great! I am still a newcomer to Linux so bear with me but will try what you have passed on to me. Thanks.

This might help you. Someone got help with using the terminal. You use: cd to change directories. You can probably press tab for it to automatically show your directory options based on what you typed. To open a log, you can use: nano [file name]

I think it would be easiest for you to take a screenshot, but maybe there’s some way to transfer the log in order to paste it here. Actually Ctrl + Alt + F6 is the way to return to tty6, the GUI. Once you have the error log, you could make a github issue… I don’t think anyone mentions using the WWAN slot to install Qubes there. Does Qubes let you try out the the desktop environment with some default apps while installing, like Ubuntu and other distros? If so, you could probably just use a browser to copy and paste your code.

Have you installed Qubes successfully with an SSD in a caddy? I actually did install Qubes before on a T450s with this storage setup. I had to use the “dd” option when formatting the USB with Rufus instead of the “iso” mode.

One person mentions mSATA in the github issues.

FWIW, I use a now-ancient Samsung 850 mSATA as a boot drive on my primary qubes laptop and don’t appear to have any issues.

Noted. FYI, both my x230 and T430 laptops have been corebooted via Skulls

I wonder whether that will effect the mSata WWAN slot.

Is WWAN the only way to use an mSATA or is there a dedicated slot? Then that one person mentioning their ancient mSATA may not prove much.

For both ThinkPad X230 and T430, yes, the WWAN slot is the only way to use an mSATA drive. The other person is mentioning an “ancient” mSATA that’s just the drive itself as it’s a Samsung mSATA, which is not being produced anymore by Samsung.

I think you should make a github issue to get proper support. I chose a SATA SSD for peace-of-mind.