Short list of laptops/desktops that work well with Qubes OS

Not so - the maximum RAM is 16GB

I agree that machines with maximum less than 16GB should not be
included.

1 Like

Think this requires a bios flash. What I had to do on my x220.

Hehe, I had an x220 spare, seen the x220/x230 were being recommended. Upgraded ssd and up to 16gb ram. Not really possible as a daily driver. Was good to explore qubes as a complete beginner (to Linux and computing too) but even using the x220 piqued my interest to invest in a better machine.

I’ve been working with these machines for years - I’ve never flashed the
BIOS just to get the 16GB recognised, usually with 1866MHz DDR3.
Since you don’t say what you flashed, or what RAM you were using, I cant
comment on your case.
It shouldn’t affect this list, since it aims at machines that can be
bought and run “as is”.

1 Like

My apologies went back and looked at the flash and it was to reach 1866mhz.

@unman wrote:

Not so - the maximum RAM is 16GB

Interesting, the official specs for both X220 and X220 Tablet say otherwise:

https://support.lenovo.com/kn/en/solutions/pd015812-detailed-specifications-thinkpad-x220

https://support.lenovo.com/kn/en/solutions/pd015807-detailed-specifications-thinkpad-x220-tablet

So if you can confirm that 16 GB works in those machines, despite the
spec saying otherwise – I am glad to add them to the list.

There is one more HCL report showing X220 with 16 GM RAM:

Adding it to the list.

That’s what I’ve been using but I have not done any testing. Just general use which seems fine.

@adw wrote:

T450s

I’ll gladly add it to the list. At the moment it has 6 positive reports
for R3.x … since you use it, would you mind submitting an updated HCL
report for R4.0 please?

Lenovo Thinkpad X 230. I actually had issues trying to install 4.0.4. Where I first went into BIOS and discovered that Virtualization was not enabled. I tried to change it, and with multiple reboots it still had install problems. Virtualization not working. Ubuntu worked.

I tried two things at the same time. I put in a Spinning Hard Drive. Installed Windows, (gag). Then updated BIOS. Then installed Qubes 4.0.4 which worked.

I have seen issues putting in a new SDD (I bought several), where the X-230 had issues seeing the drive to install Linux.

Rather than good diagnostics; When I run put in new SSD, which gives problems. I let Windows 10 do a basic install to it. Then allow a Linux Distro to install to it. Ubuntu, Mint, Fedora are things I have used.

I do not know what I am doing to make this happen. After the first time the SSD is written to, it seems to behave, and allow one to install. Windows talks to everything.

I am guessing that anyone trying an X-230, might have to change the BIOS. Which might seem problematic to new comer.

@t0t0 wrote:

Qubes 4.0 installed on my Librem 15 without a hitch.

Awesome! Currently we have two HCL reports for the Librem 15: one with
i7-6500U from Jeff Warner and one with i7-7500U from Matt DeVillier.

What CPU does yours use? If it’s one of the above that makes it two
positive reports then and that Librem can be included on the list (which
so far is ThinkPad only).

If possible it would be highly appreciated if you could send a full HCL report.

I posted a first version of the list but will continue to work on it as more feedback and reports come in. Unfortunately at the moment it’s the “Lenovo ThinkPad list”… I hope that we will get a bit more deversity soon.

@michael, @adw: pull request

@catacombs wrote:

Lenovo Thinkpad X230

I couldn’t find a HCL report from you (or maybe you submitted it using a
different user name / mailing list).

Would you mind telling me the CPU in your X230… or even better send
full HCL report?

I am guessing that anyone trying an X-230, might have to change the
BIOS. Which might seem problematic to new comer.

Yeah. Enabling Vt-d and in many cases switching to legacy boot will be
required for most. Maybe we should mention that in the post.

Thanks!

@Sven Sent the HCL. Same CPU as DeVillier.

Great @t0t0, I will add it to the list – thank you!

1 Like

Lenovo Thinkpads T470s, T480s, T490s, X250 and Carbon X8, and Lenovo Yoga 720. I installed Qubes OS for friends on these laptops over the past few years.

1 Like

I as mentioned above, Librem 15 is out of stock, not available for purchase. It does not fulfill condition 4. I doubt there are many used laptops available on the market.

Done.

@marmarek, do you need the hardware testing page?

Seemed to me that changing BIOS to use Virtualization was part of the other documentation.

I am not sure which thing I did to get it to utilize Virtualization to function. I think I used some drive format-er to explicitly write across all the drive, as I was gun-shy that the size of clusters, other things left by having NTFS on it first.

It is a core I5.

I can not duplicate the issues, as I have since installed Skulls Core Boot, and I am not sure if I got it to accept the Flash on the other chip, to get rid of the objectionable part of Intel ME.

I still hope to Re Flash using the Heads site as a guide. First I need to buy another Flash Clip, and a NitroKey. And. Do a lot of reading to make sure it is a go, to change from where I am to using a Nitro Key. Reason I say that is, IF one is thinking of doing the Flashing, might be better to not use the Skulls (on GitHub) version and start with Heads site.

Skulls site is excellent for providing the information and links to rolling back the BIOS to a point where one can Flash (with an external Programmer).

I am on what the US calls old age pension, Social Security. Might be a few months to buy more parts.

The Oddity to beware of, the Lenovo X-230 is older than the SSD’s that I am trying to put into it. Perhaps the newer BIOS will recognize and use a new SSD. After the SSD is used once, then it seems I can use any Linux Distro to format and install to it. Perhaps 4.1 will not have this issue either.

Based on what I have been told: Perhaps it might be duplicated in the basic talk about using an Lenovo X-230, that to upgrade the Wireless Chip, and perhaps it is use a Third Party battery, one must do some kind of alteration of the BIOS. The Atheros Chip used by Insurgo, is much better than the standard Intel Chip it comes with.

Upgrading memory can be expensive. I spent over a hundred to put in 16 GB, came with 4 GB. Somewhere, I seem to recall there is a note that the faster RAM can become a hazard to doing some things with BIOS. I don’t recall where that was.

I seem to make every mistake that can be made.

I would bet this would be a common set of potential problems with the T430. So not sure if the HCL is where to put my little workarounds.

Sven, thanks for working on the HCL.