Short list of laptops/desktops that work well with Qubes OS

Apologies guys I completely missed the point around having 2 HCLs as a requirement.

No worries I will do another HCL for the system76 lemur pro shortly. Although mine is a i7-10510U.

For the kde slimbook and the tuxedo infinity, unfortunately I don’t have access to them to complete the HCL. So disregard my comments there.

Hi guys
just submitted the HCL then

1 Like

It seems to support standard Markdown tables:

Header1 Header2 Header3
data1 data2 data3
data11 data12 data13
1 Like

Thanks @adw … I’ll get on it in the next days! Still doing my other “homework” (VPN/Tor/Whonix etc)

2 posts were split to a new topic: Purism Librem 14 v1

2 posts were split to a new topic: Lenovo ThinkPad T470s

Hello. I have been using Qubes 4.0.4 for a long time on my Thinkpad T430s with 3320M processor, everything is working perfectly, where should I send the hcl?
I recently switched to the beta 4.1 rc version, everything also works perfectly for me there, except for only the keyboard layout, which I created a theme about (4.1 layout does not switch), but I do not think that this is a very serious problem. I can also provide hcl with this version of Qubes.
I have a friend using Qubes on a lenovo g505s laptop, which is completely AMD and has 16 GB of memory, according to his statement, he has 4.0.4 and 4.1 beta working well, I could ask him to provide it hcl

Change: I decided that it was necessary to determine my choice of the t430s model, maybe it will be important for someone when choosing.
The T430s differs from the T430 in its dimensions, the T430 is much lighter and more compact, just as I know it comes with a new keyboard. And at release, the T430s was much cheaper than the T430.
One thing I don’t like about the T430s is that if you want to install coreboot there you may have problems with the chip and you have to re-solder it in order to install coreboot, it can be very difficult for an inexperienced person in these matters.

@rakibiy676 wrote:

where should I send the hcl?

This category.

I can also provide hcl with [R4.1] version of Qubes.

Yes please. You can post both in one new thread at the HCL Reports category.

I have a friend using Qubes on a lenovo g505s laptop, which is completely AMD and has 16 GB of memory, according to his statement, he has 4.0.4 and 4.1 beta working well, I could ask him to provide it hcl

That would be great!

HP Elitebooks up to generation 5 work well with Qubes 4.0, and generation 6, that has the ax200 wifi chip, is supported with Qubes 4.1

Unfortunately this is not enough information, see the first post.

@Sven would it be better to separate the Qubes certified hardware list and the “just works” list? Currently, the second list contains the first one. If something is changed in the first list, you would have to edit the second one.

Instead, I suggest to add a link to certified hardware in the beginning of the post and then proceed to list the “just works” hardware without the certified machines. Something like this:

That’s alright, I just thought, if someone searched for “Elitebook” it may be encouraging for them to find this little info :woman_shrugging:

@fsflover asked:

@Sven would it be better to separate the Qubes certified hardware list

Keeping it merged has an advantage for (new) users.

Separating them has a maintenance advantage.

I volunteer to keep them synced so new users have all good options in one place. :wink:

I don’t see any advantage for the users. Quite the opposite, the current list is a mix of two different things: official and unofficial recommendations. I suggest to link to the official recommendations on top, so the users are not confused and the whole thing is better organized…

The certified hardware page is linked with each entry that is certified. All links to the “community-recommended” list from the Qubes OS website are part of a list that begins with the certified hardware.

I don’t see any way this is confusing or not well organized. I do see that removing PrivacyBeast and NitroPad would make the Librem like the only option on the list offering attestation. I don’t want that. I feel conflicted about including them as it stands (they are likely to create issues down the road and this needs to be tightly monitored).

Fool me once, …

In my opinion, it creates unnecessary clutter in the list.

This is a good thing. But not everyone comes to that page from the Qubes OS website.

I disagree and actually see it the other way around. Currently, Librem 14 is on top of the certified hardware, whereas I suggest to put it below it. I don’t understand how such change would make Librem look like the only option. To me, it looks like that now.

Just a reminder, this laptop has to be flashed with Coreboot first in order to work with Qubes. It does work well but should be included in the large HCL. :wink:

Let’s table this discussion until I transformed the list into a proper markup table (next 2-3 days max, probably earlier). I have some ideas how to make it less cluttered too. Then if you still see an issue we can reevaluate. Discussing the current form is wasted energy. OK?

1 Like

FYI, I shared the “just works” list in the Qubes subreddit (because people ask for hardware recommendations there all the time):

It appears that some users have started replying with computer models in the comments, but it’s unclear why. I’m not sure if they’re trying to suggest additions to the list or what. (One of them is already on the list, so maybe not.) Anyway, just thought I’d let you know.

1 Like

Hi. There is no reason to use 4.0.4 anymore.
x220 works good with Qubes 4.1 from daily builds and lastest heads firmware.
If anyone need I can report freshly HCL

1 Like