Short list of laptops/desktops that work well with Qubes OS

I don’t think it’s a good idea to include 8 GB models due to the following scenario:

  1. User sees 8 GB model recommended on the list.
  2. User, not yet understanding the significance of memory to running Qubes, purchases 8 GB model.
  3. User runs into OOM problems.
  4. User posts about problems on forum.
  5. People reply, “It’s because you don’t have enough RAM.”
  6. User asks, “Can I add more?”
  7. People reply, “No. You should’ve gotten a model that supports more.”
  8. User now feels cheated, like there was a bait-and-switch. “Why did you recommend this model when you knew it wasn’t going to work well?”

Now, someone might say, “You can still list the 8 GB models. Just make sure to add a warning.” But how is a prospective user supposed to really understand the meaning and significance of this warning without ever having used Qubes? Most users don’t really know how many qubes they want to run simultaneously until having established some kind of workflow.

1 Like

I think the T450s meets the criteria (HCL link). The main problems are with AEM and having to reboot at least once a week, which do not involve the specified criteria. No longer available new. Not sure how many are available on the used market.

1 Like

That sounds good to me.

@unman:

**Lenovo ThinkPad x220t with i5-2520M **

Max RAM - 16GB
Tablet fully working connected to sys-usb. (Requires minor configuration
to enable tablet rpc)

Would you mind posting the “minor configuration” to the forum so I could
link it from the list please?

To clarify: The way I read it the X220T works perfectly WITHOUT any
modification and therefore fits the bill. If one want to use it as a
tablet … THEN a “minor configuration” is needed.

The “minor configuration” required is enabling the qubes.InputTablet policy.
I’m not sure if a special note is required - after all, we dont refer
to enabling the qubes.InputMouse policy, do we?

@unman:

**Lenovo ThinkPad x230 with i5-3210M **
I asked the person who uses it now and they said 4.0 works fine.

I’m afraid I don’t use UEFI, and almost all of the reports from me will
be on machines with legacy boot or coreboot. (As the certified hardware.)

Not so - the maximum RAM is 16GB

I agree that machines with maximum less than 16GB should not be
included.

Think this requires a bios flash. What I had to do on my x220.

Hehe, I had an x220 spare, seen the x220/x230 were being recommended. Upgraded ssd and up to 16gb ram. Not really possible as a daily driver. Was good to explore qubes as a complete beginner (to Linux and computing too) but even using the x220 piqued my interest to invest in a better machine.

I’ve been working with these machines for years - I’ve never flashed the
BIOS just to get the 16GB recognised, usually with 1866MHz DDR3.
Since you don’t say what you flashed, or what RAM you were using, I cant
comment on your case.
It shouldn’t affect this list, since it aims at machines that can be
bought and run “as is”.

1 Like

My apologies went back and looked at the flash and it was to reach 1866mhz.

@unman wrote:

Not so - the maximum RAM is 16GB

Interesting, the official specs for both X220 and X220 Tablet say otherwise:

https://support.lenovo.com/kn/en/solutions/pd015812-detailed-specifications-thinkpad-x220

https://support.lenovo.com/kn/en/solutions/pd015807-detailed-specifications-thinkpad-x220-tablet

So if you can confirm that 16 GB works in those machines, despite the
spec saying otherwise – I am glad to add them to the list.

There is one more HCL report showing X220 with 16 GM RAM:

Adding it to the list.

That’s what I’ve been using but I have not done any testing. Just general use which seems fine.

@adw wrote:

T450s

I’ll gladly add it to the list. At the moment it has 6 positive reports
for R3.x … since you use it, would you mind submitting an updated HCL
report for R4.0 please?

Lenovo Thinkpad X 230. I actually had issues trying to install 4.0.4. Where I first went into BIOS and discovered that Virtualization was not enabled. I tried to change it, and with multiple reboots it still had install problems. Virtualization not working. Ubuntu worked.

I tried two things at the same time. I put in a Spinning Hard Drive. Installed Windows, (gag). Then updated BIOS. Then installed Qubes 4.0.4 which worked.

I have seen issues putting in a new SDD (I bought several), where the X-230 had issues seeing the drive to install Linux.

Rather than good diagnostics; When I run put in new SSD, which gives problems. I let Windows 10 do a basic install to it. Then allow a Linux Distro to install to it. Ubuntu, Mint, Fedora are things I have used.

I do not know what I am doing to make this happen. After the first time the SSD is written to, it seems to behave, and allow one to install. Windows talks to everything.

I am guessing that anyone trying an X-230, might have to change the BIOS. Which might seem problematic to new comer.

@t0t0 wrote:

Qubes 4.0 installed on my Librem 15 without a hitch.

Awesome! Currently we have two HCL reports for the Librem 15: one with
i7-6500U from Jeff Warner and one with i7-7500U from Matt DeVillier.

What CPU does yours use? If it’s one of the above that makes it two
positive reports then and that Librem can be included on the list (which
so far is ThinkPad only).

If possible it would be highly appreciated if you could send a full HCL report.

I posted a first version of the list but will continue to work on it as more feedback and reports come in. Unfortunately at the moment it’s the “Lenovo ThinkPad list”… I hope that we will get a bit more deversity soon.

@michael, @adw: pull request

@catacombs wrote:

Lenovo Thinkpad X230

I couldn’t find a HCL report from you (or maybe you submitted it using a
different user name / mailing list).

Would you mind telling me the CPU in your X230… or even better send
full HCL report?

I am guessing that anyone trying an X-230, might have to change the
BIOS. Which might seem problematic to new comer.

Yeah. Enabling Vt-d and in many cases switching to legacy boot will be
required for most. Maybe we should mention that in the post.

Thanks!

@Sven Sent the HCL. Same CPU as DeVillier.

Great @t0t0, I will add it to the list – thank you!

1 Like