Scratchy sound quality and no fullscreen in Windows Qubes

Hiya everyone

I’ve tried to install Windows 7 and 10 on a virtual machine and have had mixed success.

I’ve found some workaround solutions, that I’d like to share with you all.

For all my Windows Qubes I’ve had trouble with getting clear sound. Initially I only managed to get some scratchy distorted sound and I couldn’t get fullscreen to work. These two problems and their corresponding solutions apply to both standalone VMs and AppVMs based on templates. The solutions are as follows:

Sound: I’ve found, that if you open up the PulseAudio Volume Control program inside dom0, then all of a sudden, the sound quality is crisp clear.

Fullscreen: I haven’t yet managed to get full fullscreen but close. Inside Controlpanel in the Windows qube open up the display settings and choose the highest resolution that covers the vertical part of the screen. This will cover around 80 % of the horizontal part of the screen if your screen is anything like mine.

Hope this helps. Cheers!

You should investigate it further, looks like a bug. Maybe report to issue tracker on github. Maybe you will be able to improve sound for everyone.

What do you mean when you say fullscreen? That resolution of Windows is the same as display native resolution?
Windows resolutions are limited to some pre-set list of those. If your display size is there you can make windows qube look full screen. I would use devilspe2 rule to move window to (0,0) and remove decorations (to emulate fullscreen).
If your display size is not provided in the list - it makes things harder. You will have to compile seabios to include custom resolution. Because, unfortunately, Qubes OS does not support arbitrary resolutions in Windows qubes like VirtualBox can.

OK, I found your issue. It was reported before:

1 Like

I fixed the audio issue by going into bios and disabling the microphone inpput

1 Like

Another workaround:

With snd_intel_dspcfg.dsp_driver=1 the issue doesn’t
happen anymore, the audio output just works the whole time. But, the
built-in microphone disappeared, only external (unplugged) is listed. I
guess that’s kind-of expected.

Sound: My bios doesn’t have the possibility to disable mic input. I’ve tried running: “snd_intel_dspcfg.dsp_driver=1” in the dom0 terminal, but I get the respons: "Command not found. So I guess I’ll just continue to open the PulseAudio Volume Control to get good sound.

@balko. By full fullscreen I mean having the windows qube (including the qubes-specific colored top-header) extending the entire screen minus the dom0 taskbar at the bottom of the screen. There is no native display resolution in windows that fits my normal-size laptop screen.

It is not a terminal command, it is a kernel boot option.

k, I know absolutely nothing about that :slight_smile:

OK, then, maybe, you should not do anything till it fixed by Qubes OS team. Maybe subscribe to the github issues I provided above to follow the changes.

But if you want to know how to set additional kernel options, you can search for something like kernel boot option on the forum.