Running QubesOS in QubesOS

Has anyone had luck running QubesOS inside QubesOS? Is there a guide on how to do this?

I’m writing another guide on how to run BusKill in QubesOS, and I need to take a screenshot of the “Q” Application Menubar – but apparently you cannot take a screenshot in dom0 while the menubar is open??

Please let me know the best way to run QubesOS inside of QubesOS (as an AppVM).

This is not possible. The only working way is Qubes OS inside KVM that work nice for testing.

2 posts were merged into an existing topic: How do I take a screenshot in dom0 while the menu is open?

@fepitre, may I ask why, technically speaking ?
I’m using Qubes 4.1 nested on a Debian Xen dom0 and it “works”.
Of course it’s hackish+unsecure (esp. to get the network), and not everything works (PV qubes only).
But, only considering nesting, what is Qubes restricting that my dom0 isn’t ?

(sorry to hijack your thread Michael)

This is mostly disabled for security reasons. @marmarek could certainly develop more the Xen internal parts.

As @fepitre said, nested virtualization is disabled in Qubes for security reasons (it isn’t security supported in Xen, at least not yet). But if you use just PV, besides having to configure quite a few things manually (like, sys-net and sys-usb), it should work, at least in theory. That said, it’s probably not worth the effort if you are just after making screenshots.

As for screenshots with menu open, the xfce screenshot tool has an option to take screenshot with a delay (run it without arguments - xfce4-screenshooter, I have it bound to ctrl+prnscr, but that’s my custom setting), and then you should be able to capture open menu.

1 Like

@zithro how did you get this to work? Is there a guide anywhere?

I downloaded the latest QubesOS .iso, created a new AppVM named my_qubes_vm, set it to boot to the .iso and set the virtualization mode to PV. On booting it, I got the following error

Qubes my_qubes_vm has failed to start: Internal error: libxenlight failed to create new domain ‘my_qubes_vm’

I also tried changing the virtualization mode from PV to HVM. This made it further; it booted to the grub boot menu, but when I selected Install Qubes OS R4.1.2, it starts to boot and then abruptly shuts-down after ~20 seconds.

(xfce4-screenshooter is definitely a good workaround, but for my documentation, I’d like a screenshot of the application menu with a fresh install; I have so many darn AppVMs that it’s cluttered and distracting)

What about Dom0 screen recorder for 4.1 - #5 by GWeck?

@marmarek can you easily toggle nesting ?
Like: enable nesting, do some tests, disable nesting ?
(Maybe that’s why I can only run PV qubes in my nested Qubes ?)

@maltfield I don’t run Qubes-in-Qubes, I run Qubes-in-Xen, it’s not exactly the same thing. If Marek tells us how it’s disabled, I may help you, provided you understand the security implications !
I’ve posted my findings here : Installing Qubes 4.1 in a Xen HVM domU (nestedhvm=1)
The nested Qubes must be HVM, and have those parameters (you will have to use Custom libvirt (ie domU) config [! dirty doc - v4.1.25-0-ga7649998] to set those params to your nested Qubes) :

  • nestedhvm = 1
  • hap = 1
  • cpuid = [‘0x1:ecx=0xxxxxxxxxxxxxxxxxxxxxxxxxxxxxxx’] (note that it works without this param on my setup)