R4.2rc4 clean install - first impression

I’ve installed 4.2rc4 on an older laptop and so far all is good :+1: Have been using this new install since last evening, for some casual browsing, writing forum comments like this one, leisure coding in geany (I know…), etc.

So on the plus side, the system is stable. On the downside, it’s uglier than 4.1 :grimacing: - but I’m picky and I don’t like change. Seriously, I know I can customise the menus and all - but after using 4.1 for a long time, the XFCE menus look a little bit out of proportion and unpolished. I use the fedora-38-xfce template extensively in my day to day work in 4.1 and I like XFCE in general, just that it maybe needs some fine-tuning. Ok, enough complaining.

Other than that, the functionality is there, and everything I tried, worked: Copy/Move to VM (renamed to “… another qube”, nice!), Convert/Edit/View in Another Cube, both from Thunar and from the command-line.
Re-enabled “smt=on” with “sched-gran=core” because my security stance permits this. No issues.
Will continue with some nftables tinkering, VPN qube(s), maybe sys-gui for VNC.

Many thanks and “well done!” to the Qubes team!



can you post some screenshots?

1 Like

That’s surprising, it looks quite similar to me?

Maybe it’s due of the use of the xfce fedora template which may have a different gtk theme than the gnome fedora template?

1 Like


I can’t take a screenshot of the menu (or I don’t know how). Maybe with a phone…

1 Like

Qubes Menu > System Tools > Screenshot

This will save .png files to your dom0. Then move those screenshots to your web browser qube and post here.

1 Like

Whisker for the win. Once the new menu (which, I admit, has the great template/standalone/app folders) is sleek-ified, I’ll revert. For now Whisker is a great alt.

1 Like

Menu fonts seem too large… the menu spacing is inconsistent… the behaviour of the menu is different in different places: on the leftmost vertical, you have to click the icons. On the other two verticals, the menus expand automatically.

Another small annoyance: the “updates available” icon used to be an orange Sun :sun_with_face: in 4.1, urging you to update. In 4.2 this icon is a little black “down arrow” on a mostly black background, not attracting attention nor imparting any sense of urgency.

But again, these issues are all cosmetic. The system is stable which is probably the most important thing.


I never saw that :exploding_head: it always have been a grey thing

Wow. Did you run a clean install of 4.1? Or rather, when and how did you install 4.1?
On my main machine, I think I reinstalled 4.1.1 some time in February or March this year…

For me it looks like this (in 4.1) :

1 Like

Please feel free to open an issue for these. :slight_smile:

1 Like

Yeah, thanks, these are “my thoughts” as I said in the title. Not really bugs.
If I find something worth reporting, I will. :slight_smile:

I just have bad memory, and I used more 4.2 than 4.1 so I already forgot :joy:

1 Like

yeah, I can see that, too.

This sounds disappointing.


Update: I found the old menu, just right-click on the desktop and choose “Applications…” :smile:

The new menu is only an xfce panel element, you can replace it with the old menu.

1 Like

Yes. I was just complaining that the new menu is a downgrade from the old one. “First impression”, right? You can’t get a second “first impression”. :joy:

My first impression wasn’t happy either, but I got to like it more than the old menu :+1:

I also discovered that using alt+F3 allows to type a few words to find a program name which includes the qube name, it’s super easy to find something this way.